summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:44:42 -0700
committerAnatol Pomozov2015-06-17 08:44:42 -0700
commit6da5b07567f661f19280eb900c8f29053abaef9c (patch)
tree22e400ef68a5b8fc70ef3abfd1e267de55468ba6
downloadaur-6da5b07567f661f19280eb900c8f29053abaef9c.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
-rw-r--r--shared_lib.patch42
4 files changed, 108 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6662e0e77c60
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = double-conversion
+ pkgdesc = Binary-decimal and decimal-binary routines for IEEE doubles
+ pkgver = 2.0.1
+ pkgrel = 2
+ url = https://code.google.com/p/double-conversion/
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ makedepends = cmake
+ source = https://double-conversion.googlecode.com/files/double-conversion-2.0.1.tar.gz
+ source = shared_lib.patch
+
+pkgname = double-conversion
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..334cab23e91b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = double-conversion
+ pkgdesc = Binary-decimal and decimal-binary routines for IEEE doubles
+ pkgver = 2.0.1
+ pkgrel = 2
+ url = https://code.google.com/p/double-conversion/
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ makedepends = cmake
+ source = https://double-conversion.googlecode.com/files/double-conversion-2.0.1.tar.gz
+ source = shared_lib.patch
+ sha1sums = 34644bfd063aba87436536e029b0dfb109df850f
+ sha1sums = 54abeec2090908c7ed229986826e8cce400edd1b
+
+pkgname = double-conversion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..201632cc19e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Joel Teichroeb <joel@teichroeb.net>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=double-conversion
+pkgver=2.0.1
+pkgrel=2
+pkgdesc='Binary-decimal and decimal-binary routines for IEEE doubles'
+arch=(i686 x86_64)
+url='https://code.google.com/p/double-conversion/'
+license=(BSD3)
+makedepends=(cmake)
+source=(https://double-conversion.googlecode.com/files/$pkgname-$pkgver.tar.gz
+ shared_lib.patch)
+sha1sums=('34644bfd063aba87436536e029b0dfb109df850f'
+ '54abeec2090908c7ed229986826e8cce400edd1b')
+
+prepare() {
+ patch -p1 < shared_lib.patch
+}
+
+build() {
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=ON
+ make
+}
+
+check() {
+ cd test
+ cmake .
+# Currently tests fail
+# make all
+}
+
+package () {
+ make DESTDIR="$pkgdir" install
+}
diff --git a/shared_lib.patch b/shared_lib.patch
new file mode 100644
index 000000000000..e39823fbca74
--- /dev/null
+++ b/shared_lib.patch
@@ -0,0 +1,42 @@
+commit c7734598e2ee084c17e1b8a41daa569fb021d593
+Author: Florian Loitsch <florian@loitsch.com>
+Date: Sat Mar 8 15:02:13 2014 +0100
+
+ Support shared libraries with Cmake. Improve README.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5bf382e..7b09be0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,8 +2,12 @@ cmake_minimum_required(VERSION 2.8)
+ project(double-conversion)
+
+ # pick a version #
+-set(double-conversion_VERSION
+- 1.1.1)
++set(double-conversion_VERSION 2.0.1)
++set(double-conversion_SOVERSION_MAJOR 1)
++set(double-conversion_SOVERSION_MINOR 0)
++set(double-conversion_SOVERSION_PATCH 0)
++set(double-conversion_SOVERSION
++ ${double-conversion_SOVERSION_MAJOR}.${double-conversion_SOVERSION_MINOR}.${double-conversion_SOVERSION_PATCH})
+
+ # set paths for install -- empty initially
+ # Offer the user the choice of overriding the installation directories
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 7f5c985..0da50b1 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -29,6 +29,12 @@ ${headers}
+ set_target_properties(double-conversion
+ PROPERTIES PUBLIC_HEADER "${headers}")
+
++if (BUILD_SHARED_LIBS)
++ set_target_properties(double-conversion
++ PROPERTIES VERSION ${double-conversion_SOVERSION}
++ SOVERSION ${double-conversion_SOVERSION_MAJOR})
++endif()
++
+ #
+ # install command to set up library install
+ # given the above PUBLIC_HEADER property set, this