summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregor Reitzenstein2017-01-24 11:42:24 +0100
committerGregor Reitzenstein2017-01-24 11:42:24 +0100
commitadb8d91fcb50a089f54e2d80b909b887073831f7 (patch)
treedfc87041d8a2d0d9742851d4712ce7d540ea399e
downloadaur-adb8d91fcb50a089f54e2d80b909b887073831f7.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4d35629050e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dovecot-libsodium-plugin
+ pkgdesc = Dovecot libsodium plugin for Argon2 & SCRYPT hashing schemes
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/LuckyFellow/dovecot-libsodium-plugin
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = dovecot
+ depends = dovecot
+ source = git+https://github.com/LuckyFellow/dovecot-libsodium-plugin.git
+ sha512sums = SKIP
+
+pkgname = dovecot-libsodium-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8477b0f3c6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gregor Reitzenstein <dean4devil at paranoidlabs.org>
+
+pkgname=dovecot-libsodium-plugin
+pkgver=1.0
+pkgrel=1
+pkgdesc='Dovecot libsodium plugin for Argon2 & SCRYPT hashing schemes'
+url='https://github.com/LuckyFellow/dovecot-libsodium-plugin'
+arch=('any')
+license=('GPL3')
+depends=('dovecot' 'libsodium')
+makedepends=('git')
+source=('git+https://github.com/LuckyFellow/dovecot-libsodium-plugin.git')
+sha512sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ ./autogen.sh
+
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ install -d -m 755 ${pkgdir}/usr/lib/dovecot/modules/auth/
+
+ install -D -m 644 ${srcdir}/${pkgname}/src/.libs/libsodium_plugin.so ${pkgdir}/usr/lib/dovecot/modules/auth/
+}