summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2017-05-09 13:41:05 +0200
committerfrederik2017-05-09 13:41:05 +0200
commit9f2a4f580594484b52826d94b9b68f08fdffc8a4 (patch)
tree04c082056af20c2dd9b06bde361c496ba6a5493f
parent94b4e694846251d092e51c9c672b8590eb9506ba (diff)
downloadaur-9f2a4f580594484b52826d94b9b68f08fdffc8a4.tar.gz
improve PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a1272b7711e..fb720b9d3dc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Fri Nov 25 19:30:25 UTC 2016
+# Tue May 9 11:40:49 UTC 2017
pkgbase = dovecot-xaps-plugin-git
- pkgdesc = iOS Push Email for Dovecot
+ pkgdesc = iOS Push Email for Dovecot - dovecot plugin
pkgver = 22.92c51b5
pkgrel = 1
url = https://github.com/st3fan/dovecot-xaps-plugin
@@ -9,6 +9,7 @@ pkgbase = dovecot-xaps-plugin-git
license = MIT
makedepends = git
depends = dovecot
+ depends = dovecot-xaps-daemon-git
source = git+https://github.com/st3fan/dovecot-xaps-plugin.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a878a423f5dd..d958ee94f1eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,27 @@ pkgname=dovecot-xaps-plugin-git
_gitname=dovecot-xaps-plugin
pkgver=22.92c51b5
pkgrel=1
-pkgdesc='iOS Push Email for Dovecot'
-url='https://github.com/st3fan/dovecot-xaps-plugin'
+pkgdesc='iOS Push Email for Dovecot - dovecot plugin'
arch=('any')
+url='https://github.com/st3fan/dovecot-xaps-plugin'
license=('MIT')
-depends=('dovecot')
+depends=('dovecot' 'dovecot-xaps-daemon-git')
makedepends=('git')
-source=("git+https://github.com/st3fan/dovecot-xaps-plugin.git")
+source=(git+https://github.com/st3fan/dovecot-xaps-plugin.git)
sha512sums=('SKIP')
-
+
pkgver() {
cd ${_gitname}
echo $(git rev-list --count master).$(git rev-parse --short master)
}
build() {
- cd ${srcdir}/${_gitname}
+ cd "${srcdir}/${_gitname}"
make
}
package() {
- install -d -m 755 ${pkgdir}/usr/lib/dovecot/modules/
- install -d -m 755 ${pkgdir}/usr/share/doc/dovecot/example-config/conf.d/
-
- install -D -m 644 ${srcdir}/${_gitname}/imap_xaps_plugin.so ${pkgdir}/usr/lib/dovecot/modules/
- install -D -m 644 ${srcdir}/${_gitname}/xaps_plugin.so ${pkgdir}/usr/lib/dovecot/modules/
-
- install -D -m 644 ${srcdir}/${_gitname}/xaps.conf ${pkgdir}/usr/share/doc/dovecot/example-config/conf.d/30-xaps.conf
+ install -Dm644 -t "${pkgdir}/usr/lib/dovecot/modules/" "${srcdir}/${_gitname}/imap_xaps_plugin.so"
+ install -Dm644 -t "${pkgdir}/usr/lib/dovecot/modules/" "${srcdir}/${_gitname}/xaps_plugin.so"
+ install -Dm644 "${srcdir}/${_gitname}/xaps.conf" "${pkgdir}/usr/share/doc/dovecot/example-config/conf.d/30-xaps.conf"
}