summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-07-07 13:59:44 +0200
committerGoliathLabs2020-07-07 13:59:44 +0200
commit44ff09b662eb0c29febe7d77c351df02de214e74 (patch)
tree6ecab62c6395119e97fc6cb5fcaa2c3c661f67af
parenta6419ad2f66a9112c63f6d74590fd42e538cfb22 (diff)
downloadaur-44ff09b662eb0c29febe7d77c351df02de214e74.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14df6bca3787..44e60d720d14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = dovecot2-antispam-git
pkgdesc = Integrates DSPAM into dovecot IMAP server. Git Version for dovecot >= 2.1
- pkgver = v2.0.17.g713e9e9
+ pkgver = 2.0.r17.g713e9e9
pkgrel = 1
- url = http://hg.dovecot.org/dovecot-antispam-plugin/
+ url = https://git.sipsolutions.net/dovecot-antispam.git/
arch = i686
arch = x86_64
license = GPL
@@ -10,8 +10,8 @@ pkgbase = dovecot2-antispam-git
depends = dovecot>=2.2.0
provides = dovecot-antispam
conflicts = dovecot-antispam
- source = dovecot2-antispam-git::git+http://git.sipsolutions.net/dovecot-antispam.git/
- md5sums = SKIP
+ source = dovecot2-antispam-git::git+https://git.sipsolutions.net/dovecot-antispam.git
+ sha512sums = SKIP
pkgname = dovecot2-antispam-git
diff --git a/PKGBUILD b/PKGBUILD
index 1ff65e5b0fe7..27cda2636423 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,32 @@
# Contributor: Carsten Feuls <archlinux@carstenfeuls.de>
pkgname=dovecot2-antispam-git
-pkgver=v2.0.17.g713e9e9
+pkgver=2.0.r17.g713e9e9
pkgrel=1
pkgdesc="Integrates DSPAM into dovecot IMAP server. Git Version for dovecot >= 2.1"
arch=( 'i686' 'x86_64' )
-url="http://hg.dovecot.org/dovecot-antispam-plugin/"
+url="https://git.sipsolutions.net/dovecot-antispam.git/"
license=('GPL')
depends=('dovecot>=2.2.0')
makedepends=('git')
conflicts=(dovecot-antispam)
provides=(dovecot-antispam)
-source=('dovecot2-antispam-git::git+http://git.sipsolutions.net/dovecot-antispam.git/')
-md5sums=('SKIP')
+source=('dovecot2-antispam-git::git+https://git.sipsolutions.net/dovecot-antispam.git')
+sha512sums=('SKIP')
pkgver() {
- cd ${srcdir}/${pkgname}
- git describe --always | sed 's|-|.|g'
+ cd "$srcdir/$pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${srcdir}/${pkgname}
- #./autogen.sh
- #./configure --prefix=/usr --with-dovecot=/usr/lib/dovecot
- msg "Starting make..."
+ cd "$srcdir/$pkgname"
make
}
package() {
- cd "${srcdir}/${pkgname}"
- mkdir -p "${pkgdir}/usr/lib/dovecot/modules"
- make INSTALLDIR="${pkgdir}/usr/lib/dovecot/modules" install
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr/lib/dovecot/modules"
+ make INSTALLDIR="$pkgdir/usr/lib/dovecot/modules" install
}