summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatrick brisbin2015-09-01 12:07:26 -0400
committerpatrick brisbin2015-09-01 12:07:26 -0400
commitdee7bd9b918bac4e6705e033ae5d9456d9ddfe88 (patch)
treebfff0aa5ea2ffd7a70bae0b1449e13742c4e3594
parent0bdb507e2793e8d22a0738d03b38e479f55c9669 (diff)
downloadaur-dee7bd9b918bac4e6705e033ae5d9456d9ddfe88.tar.gz
Release v5.1.4
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile14
-rw-r--r--PKGBUILD4
3 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5db36ba1cd..e6d3f355115a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = downgrade
pkgdesc = Bash script for downgrading one or more packages to a version in your cache or the A.R.M.
- pkgver = 5.1.3
+ pkgver = 5.1.4
pkgrel = 1
url = https://github.com/pbrisbin/downgrade
arch = any
license = GPL
optdepends = sudo: for installation via sudo
- source = https://github.com/pbrisbin/downgrade/archive/v5.1.3.tar.gz
+ source = https://github.com/pbrisbin/downgrade/archive/v5.1.4.tar.gz
md5sums = 37e82c18f56e8f0343b57edf7bf4e687
pkgname = downgrade
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..4fa36979ce24
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+VERSION = 5.1.4
+RELEASE = 1
+
+release:
+ sed -i 's/^pkgver=.*/pkgver=$(VERSION)/g' PKGBUILD
+ sed -i 's/^pkgrel=.*/pkgrel=$(RELEASE)/g' PKGBUILD
+ mksrcinfo
+ updpkgsums
+ rm v$(VERSION).tar.gz
+ git add .SRCINFO Makefile PKGBUILD
+ git commit -m "Release v$(VERSION)"
+ echo git push
+
+.PHONY: release
diff --git a/PKGBUILD b/PKGBUILD
index 1c67882c2008..4047b3e47ff2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Author: Patrick Brisbin <pbrisbin@gmail.com>
pkgname=downgrade
-pkgver=5.1.3
+pkgver=5.1.4
pkgrel=1
pkgdesc="Bash script for downgrading one or more packages to a version in your cache or the A.R.M."
arch=('any')
@@ -23,4 +23,4 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
}
-md5sums=('37e82c18f56e8f0343b57edf7bf4e687')
+md5sums=('4767451ae68b48b300c45ba811e3c268')