summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrandon Milton2016-06-05 23:10:41 -0700
committerBrandon Milton2016-06-05 23:10:41 -0700
commiteabf999f7f255f6ea03bde7bb2a1dd52fde4b267 (patch)
tree67dc5faa8a6c8599586ececfacf9753abd8c5af7
downloadaur-eabf999f7f255f6ea03bde7bb2a1dd52fde4b267.tar.gz
Intiial 1.0 release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f75059f5f22c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = download-sweeper
+ pkgdesc = A stale file archive and removal tool
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/brandonio21/download-sweeper
+ arch = any
+ license = GPL
+ makedepends = python-pip
+ depends = python>=3
+ depends = systemd
+ source = https://github.com/brandonio21/download-sweeper/archive/v1.0.tar.gz
+ md5sums = 110606cc97b00bb407831f40c03193d7
+
+pkgname = download-sweeper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b97ed37564d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Brandon Milton <brandon.milton21@gmail.com>
+pkgname=download-sweeper
+pkgver=1.0
+pkgrel=1
+pkgdesc="A stale file archive and removal tool"
+arch=('any')
+url="https://github.com/brandonio21/download-sweeper"
+license=('GPL')
+depends=('python>=3' 'systemd')
+makedepends=('python-pip')
+source=("https://github.com/brandonio21/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('110606cc97b00bb407831f40c03193d7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}