summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-12-08 10:12:25 -0700
committerMark Wagie2020-12-08 10:12:25 -0700
commit608114c8d8a286e7d795cc7d93611bc6e03eeb4f (patch)
treeaa42c300262c71214fa00af2c211e0cdf3dcf86c
parentfbfc83efb75b03eb37f6adc3eba21036cb955d09 (diff)
downloadaur-608114c8d8a286e7d795cc7d93611bc6e03eeb4f.tar.gz
2.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fba82c3b8b74..5d56d77b76b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = downzemall
pkgdesc = A mass download manager based on the Qt5 framework and written in C/C++
- pkgver = 2.1.0
- pkgrel = 2
+ pkgver = 2.2.0
+ pkgrel = 1
url = https://setvisible.github.io/DownZemAll
arch = x86_64
license = LGPL3
@@ -12,9 +12,9 @@ pkgbase = downzemall
depends = youtube-dl
optdepends = libnotify: desktop notifications
optdepends = libappindicator-gtk3: tray icon
- source = downzemall-2.1.0.tar.gz::https://github.com/setvisible/DownZemAll/archive/v2.1.0.tar.gz
+ source = downzemall-2.2.0.tar.gz::https://github.com/setvisible/DownZemAll/archive/v2.2.0.tar.gz
source = downzemall.desktop
- sha256sums = 864cf423921428dd3dca7a9730900b878b340d7ce3452fe2145cc57701c73478
+ sha256sums = 6b445a0f61b2ec5f40211cae8de5f1ed3222176cf39af2d4c0fef2ea667eb81b
sha256sums = 3cb8f2eefbd9f04dd4b3a706058d8ab82c42514db81fbfbdf213fc833ca01eff
pkgname = downzemall
diff --git a/PKGBUILD b/PKGBUILD
index 14491443af93..0682b4f1e05f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=downzemall
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.2.0
+pkgrel=1
pkgdesc="A mass download manager based on the Qt5 framework and written in C/C++"
arch=('x86_64')
url="https://setvisible.github.io/DownZemAll"
@@ -12,7 +12,7 @@ optdepends=('libnotify: desktop notifications'
'libappindicator-gtk3: tray icon')
source=("$pkgname-$pkgver.tar.gz::https://github.com/setvisible/DownZemAll/archive/v$pkgver.tar.gz"
"$pkgname.desktop")
-sha256sums=('864cf423921428dd3dca7a9730900b878b340d7ce3452fe2145cc57701c73478'
+sha256sums=('6b445a0f61b2ec5f40211cae8de5f1ed3222176cf39af2d4c0fef2ea667eb81b'
'3cb8f2eefbd9f04dd4b3a706058d8ab82c42514db81fbfbdf213fc833ca01eff')
prepare() {
@@ -24,7 +24,9 @@ prepare() {
build() {
cd "DownZemAll-$pkgver"
cmake -B build -S . \
- -DENABLE_TESTS:BOOL='OFF' \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_CXX_FLAGS_RELEASE="$CXXFLAGS" \
+ -DENABLE_TESTS=OFF \
-Wno-dev
make -C build
}
@@ -41,8 +43,6 @@ package() {
install -Dm644 web-extension/launcher/unix/launcher-manifest-firefox.json \
"$pkgdir/usr/lib/mozilla/native-messaging-hosts/DownRightNow.json"
- install -Dm644 *.md -t "$pkgdir/usr/share/doc/$pkgname"
-
install -Dm644 src/icons/logo/LICENSE \
"$pkgdir/usr/share/licenses/$pkgname/LOGO_LICENSE"