summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-05 08:49:11 -0700
committerMark Wagie2023-11-05 08:49:11 -0700
commit778d4b8cf1b01213530000e817b406ef0234f4b0 (patch)
treeec0352190f783d9615d46765b29959b2e1f9d804
parent25ddf21c211fca9e2ad7f775537a44e9a825a467 (diff)
downloadaur-778d4b8cf1b01213530000e817b406ef0234f4b0.tar.gz
add missing include
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f2cf4c9b250..d31e906102bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = downzemall
pkgdesc = A mass download manager that helps you to select, organize, prioritize and run your downloads in parallel.
pkgver = 3.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://setvisible.github.io/DownZemAll
arch = x86_64
license = LGPL3
@@ -14,7 +14,9 @@ pkgbase = downzemall
depends = yt-dlp
source = downzemall-3.0.6.tar.gz::https://github.com/setvisible/DownZemAll/archive/v3.0.6.tar.gz
source = downzemall.desktop
+ source = add-missing-include.patch
sha256sums = a5f1eefdbc83f7f3e1e72b4c6102829e511331ef96c466bfa23cb5bba543bb2f
sha256sums = 3cb8f2eefbd9f04dd4b3a706058d8ab82c42514db81fbfbdf213fc833ca01eff
+ sha256sums = 9167312e19c9239bebc5c328ec651828a2738de552fb7e7c5a54f22d15b50109
pkgname = downzemall
diff --git a/.gitignore b/.gitignore
index 08e92d0b8edb..a7a6c359eff4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@
!PKGBUILD
!.SRCINFO
!downzemall.desktop
+!add-missing-include
diff --git a/PKGBUILD b/PKGBUILD
index 0ac61f59db69..cecdcb1492c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=downzemall
pkgver=3.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="A mass download manager that helps you to select, organize, prioritize and run your downloads in parallel."
arch=('x86_64')
url="https://setvisible.github.io/DownZemAll"
@@ -9,9 +9,11 @@ license=('LGPL3' 'CC BY-SA 3.0')
depends=('libtorrent-rasterbar' 'qt6-base' 'yt-dlp')
makedepends=('boost' 'cmake' 'qt6-tools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/setvisible/DownZemAll/archive/v$pkgver.tar.gz"
- "$pkgname.desktop")
+ "$pkgname.desktop"
+ 'add-missing-include.patch')
sha256sums=('a5f1eefdbc83f7f3e1e72b4c6102829e511331ef96c466bfa23cb5bba543bb2f'
- '3cb8f2eefbd9f04dd4b3a706058d8ab82c42514db81fbfbdf213fc833ca01eff')
+ '3cb8f2eefbd9f04dd4b3a706058d8ab82c42514db81fbfbdf213fc833ca01eff'
+ '9167312e19c9239bebc5c328ec651828a2738de552fb7e7c5a54f22d15b50109')
prepare() {
cd "DownZemAll-$pkgver"
@@ -21,6 +23,9 @@ prepare() {
# Look for system shared object, not source archive
sed -i 's/libtorrent-rasterbar.a/libtorrent-rasterbar.so/g' \
cmake/Modules/FindLibtorrentRasterbar.cmake
+
+ # https://github.com/setvisible/DownZemAll/issues/120
+ patch -Np1 -i ../add-missing-include.patch
}
build() {