summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Scarpino2017-12-02 19:51:54 +0100
committerAndrea Scarpino2017-12-02 19:51:54 +0100
commit83d422a040471caa566e6818e6331dca3d8c6bbc (patch)
tree70a7521ff01aa8f86cda2004a504dc8834a8510b
parent0e8e91af05fb55efa5c43c5dbbf4adcff227803d (diff)
downloadaur-83d422a040471caa566e6818e6331dca3d8c6bbc.tar.gz
Update to latest development
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD68
-rw-r--r--dowse-sysusers.conf1
-rw-r--r--dowse.install22
-rw-r--r--[-rwxr-xr-x]dowse.service0
-rwxr-xr-xdowse.sh9
6 files changed, 94 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af4ad6896526..15588c18776b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,56 @@
+# Generated by mksrcinfo v8
+# Sat Dec 2 18:44:08 UTC 2017
pkgbase = dowse-git
pkgdesc = Minimalistic tool to configure the routing of a local area network
- pkgver = 81.e365694
+ pkgver = v0.9.r971.g0b0fc46
pkgrel = 1
url = https://github.com/dyne/dowse
- install = dowse.install
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL
makedepends = git
depends = zsh
- depends = privoxy
- depends = squid
- depends = dnsmasq
- depends = tor
- depends = daemontools
- depends = iptables
- depends = ebtables
+ depends = hiredis
+ depends = jemalloc
+ depends = libltdl
+ depends = libsodium
+ depends = ldns
+ depends = libnetfilter_queue
+ depends = uuid
+ depends = cmake
+ depends = liblo
+ depends = nmap
+ depends = python-flask
+ depends = python-redis
+ depends = xmlstarlet
+ depends = wget
provides = dowse
conflicts = dowse
- backup = usr/share/dowse/conf/network
- backup = usr/share/dowse/conf/settings
- source = git://github.com/dyne/dowse.git
+ backup = etc/dowse/network.dist
+ backup = etc/dowse/settings.dist
+ source = git+https://github.com/dyne/dowse.git
+ source = git+https://github.com/dyne/zuper.git
+ source = git+https://github.com/warmcat/libwebsockets.git
+ source = git+https://github.com/jedisct1/dnscrypt-proxy
+ source = git+https://github.com/dyne/domain-list
+ source = git+https://github.com/firehol/netdata
+ source = git+https://github.com/node-red/node-red.git
source = dowse.sh
source = dowse.service
+ source = dowse-sysusers.conf
md5sums = SKIP
- md5sums = 4d296e0099e15aa82fdf42fbe111dc5d
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = c06037c6ec5f08fd9e401bec078f5068
md5sums = 112e9e1e5b0bee78abdd09dba2e7606d
+ md5sums = 460d04d7632b4431b4d454326b03a9f0
pkgname = dowse-git
diff --git a/PKGBUILD b/PKGBUILD
index dbf9a19daf46..6e0151a43408 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,68 @@
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
pkgname=dowse-git
-pkgver=81.e365694
+pkgver=v0.9.r971.g0b0fc46
pkgrel=1
pkgdesc='Minimalistic tool to configure the routing of a local area network'
-arch=('any')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='https://github.com/dyne/dowse'
license=('GPL')
-depends=('zsh' 'privoxy' 'squid' 'dnsmasq' 'tor' 'daemontools' 'iptables' 'ebtables')
+depends=('zsh' 'hiredis' 'jemalloc' 'libltdl' 'libsodium' 'ldns' 'libnetfilter_queue' 'uuid' 'cmake' 'liblo' 'nmap' 'python-flask' 'python-redis' 'xmlstarlet' 'wget')
makedepends=('git')
conflicts=('dowse')
provides=('dowse')
-backup=('usr/share/dowse/conf/network' 'usr/share/dowse/conf/settings')
-install=dowse.install
-source=('git://github.com/dyne/dowse.git'
- 'dowse.sh'
- 'dowse.service')
+backup=('etc/dowse/network.dist' 'etc/dowse/settings.dist')
+source=('git+https://github.com/dyne/dowse.git'
+ 'git+https://github.com/dyne/zuper.git'
+ 'git+https://github.com/warmcat/libwebsockets.git'
+ 'git+https://github.com/jedisct1/dnscrypt-proxy'
+ 'git+https://github.com/dyne/domain-list'
+ 'git+https://github.com/firehol/netdata'
+ 'git+https://github.com/node-red/node-red.git'
+ 'dowse.sh' 'dowse.service' 'dowse-sysusers.conf')
md5sums=('SKIP'
- '4d296e0099e15aa82fdf42fbe111dc5d'
- '112e9e1e5b0bee78abdd09dba2e7606d')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '0fc748c686944f0d9432c6a5f71d3bc3'
+ '112e9e1e5b0bee78abdd09dba2e7606d'
+ '460d04d7632b4431b4d454326b03a9f0')
pkgver() {
cd dowse
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
+prepare() {
+ cd dowse
+ git submodule init
+ git config submodule.zuper.url "$srcdir/zuper"
+ git config submodule.src/libwebsockets.url "$srcdir/libwebsockets"
+ git config submodule.src/dnscrypt-proxy.url "$srcdir/dnscrypt-proxy"
+ git config submodule.src/domain-list.url "$srcdir/domain-list"
+ git config submodule.src/netdata.url "$srcdir/netdata"
+ git config submodule.src/node-red.url "$srcdir/node-red"
+ git submodule update
+
+ sed -i 's:DOWSE_HOME =.*:DOWSE_HOME = /usr/share/dowse:' config.mk
+}
+
+build() {
cd dowse
- install -d "${pkgdir}"/usr/share/dowse/conf
- install -m755 dowse "${pkgdir}"/usr/share/dowse/
- cp -r {modules,zlibs} "${pkgdir}"/usr/share/dowse/
- touch "${pkgdir}"/usr/share/dowse/conf/{network,settings}
+ unset LDFLAGS # mosquitto doesn't build with relro,now
+ make PREFIX=/usr/share/dowse
+}
- install -d "${pkgdir}"/usr/share/doc/dowse
- cp -r {conf,doc} "${pkgdir}"/usr/share/doc/dowse/
+package() {
+ cd dowse
+ make DESTDIR="${pkgdir}" PREFIX=/usr/share/dowse install
- install -D "${srcdir}"/dowse.sh "${pkgdir}"/usr/bin/dowse
+ chown -R 1988:1988 "${pkgdir}/usr/share/dowse"
- install -d "${pkgdir}"/usr/lib/systemd/system
- install "${srcdir}"/dowse.service "${pkgdir}"/usr/lib/systemd/system/
+ install -Dm0644 "${srcdir}"/dowse-sysusers.conf "${pkgdir}/usr/lib/sysusers.d/dowse.conf"
+ install -d "${pkgdir}/usr/lib/systemd/system"
+ install "${srcdir}/dowse.service" "${pkgdir}/usr/lib/systemd/system/"
}
diff --git a/dowse-sysusers.conf b/dowse-sysusers.conf
new file mode 100644
index 000000000000..cef84a299556
--- /dev/null
+++ b/dowse-sysusers.conf
@@ -0,0 +1 @@
+u dowse 1988 "Dowse" /usr/share/dowse
diff --git a/dowse.install b/dowse.install
deleted file mode 100644
index 4f6a64ffdf70..000000000000
--- a/dowse.install
+++ /dev/null
@@ -1,22 +0,0 @@
-post_install() {
- getent group dowse >/dev/null 2>&1 || groupadd -r dowse
- getent passwd dowse >/dev/null 2>&1 || useradd -g dowse -d /usr/share/dowse -s /bin/zsh -r dowse
- chown -R dowse:dowse /usr/share/dowse
-
- echo "==> In order to configure dowse you need to adjust both 'network' and 'settings' files"
- echo " into dowse configuration dir: /usr/share/dowse/conf. See /usr/share/doc/dowse/conf"
- echo " for exmaples."
-}
-
-post_upgrade() {
- post_install
-}
-
-pre_remove() {
- if getent passwd dowse >/dev/null 2>&1; then
- userdel dowse
- fi
- if getent group dowse >/dev/null 2>&1; then
- groupdel dowse
- fi
-}
diff --git a/dowse.service b/dowse.service
index 2cf3dd64be1f..2cf3dd64be1f 100755..100644
--- a/dowse.service
+++ b/dowse.service
diff --git a/dowse.sh b/dowse.sh
index e3315c27d8de..0d013db1c730 100755
--- a/dowse.sh
+++ b/dowse.sh
@@ -1,4 +1,7 @@
-#!/bin/sh
+#!/bin/zsh
-cd /usr/share/dowse
-zsh ./dowse "$@"
+export DOWSE_PREFIX=/usr/share/dowse
+
+source $DOWSE_PREFIX/dowse
+
+dowse-start