summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWouter Haffmans2013-12-26 14:01:15 +0100
committerWouter Haffmans2015-07-22 22:34:50 +0200
commit60d66b050b62adc4bc21d254ce1decbc2761a775 (patch)
tree84461164c96669ee2d3dc197297908356edf5c1a
downloadaur-60d66b050b62adc4bc21d254ce1decbc2761a775.tar.gz
Initial version (first one put on AUR)
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e32ecc13602
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = doxygen-git
+ pkgdesc = A documentation system for C++, C, Java, IDL and PHP - git version
+ pkgver = Release_1_8_10.32.g45e153f
+ pkgrel = 1
+ url = http://www.doxygen.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = perl
+ makedepends = flex
+ makedepends = bison
+ makedepends = python2
+ depends = qt5-base
+ optdepends = graphviz: enable dot support
+ provides = doxygen
+ conflicts = doxygen
+ replaces = doxygen-svn
+ source = doxygen-git::git+https://github.com/doxygen/doxygen.git
+ md5sums = SKIP
+
+pkgname = doxygen-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ac6da291cf05
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+doxygen-git
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..526d022ffc59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Wouter Haffmans <wouter@simply-life.net>
+pkgname=doxygen-git
+pkgver=Release_1_8_5.71.g94a299a
+pkgrel=1
+pkgdesc="A documentation system for C++, C, Java, IDL and PHP - git version"
+arch=('i686' 'x86_64')
+url="http://www.doxygen.org"
+license=('GPL2')
+# Qt4 required for doxywizard
+depends=('qt4')
+makedepends=('git' 'perl' 'flex' 'bison' 'python2')
+optdepends=('graphviz')
+conflicts=('doxygen')
+provides=('doxygen')
+replaces=('doxygen-svn')
+source=("$pkgname"::'git+https://github.com/doxygen/doxygen.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # Use the tag of the last commit
+ local ver="$(git describe --long)"
+ printf "%s" "${ver//-/.}"
+}
+
+build() {
+ cd "$pkgname"
+ ./configure --prefix /usr --with-doxywizard
+ # Use python2 where necessary for doxywizard, instead of python (which is python3)
+ sed -i 's/^\(.*\)\.commands = python /\1.commands = python2 /' addon/doxywizard/doxywizard.pro
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}
+