summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2015-12-10 08:57:21 -0200
committerRafael Reggiani Manzo2015-12-10 08:57:21 -0200
commit35c300565208a14aea71b4839930b5f046b48315 (patch)
tree900c7f958940c107aab09a69955eb18e6de7bcc7
parent999ee58917cbeb45c78851bb3d288d487303da72 (diff)
downloadaur-35c300565208a14aea71b4839930b5f046b48315.tar.gz
New release compatible with flex 2.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-Flex-version-compilation-restriction.patch283
-rw-r--r--PKGBUILD16
-rw-r--r--qtools.patch35
4 files changed, 297 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea80ca0b02a9..2f723bb87adb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Dec 10 10:56:03 UTC 2015
pkgbase = doxyparse
pkgdesc = Parses source code and dumps the dependencies between the code elements.
pkgver = 1.5.9_20090622
- pkgrel = 4
+ pkgrel = 5
url = http://analizo.org
arch = any
groups = analizo
@@ -9,8 +11,8 @@ pkgbase = doxyparse
makedepends = qt4
makedepends = git
makedepends = flex
- source = qtools.patch
- sha512sums = 8095af5f6ba616864be6389b4245ab7a3a3723298635831c4f714468d6768cf86a382802ad8189053414f7701654ef683d1342936a31b98208ebf78f5e92485a
+ source = 0001-Fix-Flex-version-compilation-restriction.patch
+ sha512sums = 9c3f836ede511108d3af78d316854dc386a188f5a59add6d5e7df272abdaa4f93a2b2147617e2d46716065c51f149638977269a14ceef6fc12c02c7b3eac33e4
pkgname = doxyparse
diff --git a/0001-Fix-Flex-version-compilation-restriction.patch b/0001-Fix-Flex-version-compilation-restriction.patch
new file mode 100644
index 000000000000..7cdcec1d35ea
--- /dev/null
+++ b/0001-Fix-Flex-version-compilation-restriction.patch
@@ -0,0 +1,283 @@
+From 449ac8c3c81a82a7e86019ca4401b78d7f387f47 Mon Sep 17 00:00:00 2001
+From: Rafael Reggiani Manzo <rr.manzo@gmail.com>
+Date: Thu, 10 Dec 2015 08:01:42 -0200
+Subject: [PATCH] Fix Flex version compilation restriction
+
+The macro did not handled the case of flex 2.6.0.
+---
+ src/code.l | 4 ++--
+ src/commentcnv.l | 2 +-
+ src/commentscan.l | 6 +++---
+ src/declinfo.l | 2 +-
+ src/defargs.l | 2 +-
+ src/doctokenizer.l | 2 +-
+ src/fortrancode.l | 4 ++--
+ src/fortranscanner.l | 2 +-
+ src/pre.l | 4 ++--
+ src/pycode.l | 4 ++--
+ src/pyscanner.l | 2 +-
+ src/scanner.l | 2 +-
+ src/tclscanner.l | 2 +-
+ src/vhdlcode.l | 6 +++---
+ src/xmlcode.l | 4 ++--
+ 15 files changed, 24 insertions(+), 24 deletions(-)
+
+diff --git a/src/code.l b/src/code.l
+index c024f6c..4ae27d9 100644
+--- a/src/code.l
++++ b/src/code.l
+@@ -3741,11 +3741,11 @@ void codeFreeScanner()
+
+
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void codeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
+ #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
+ #endif
+
+diff --git a/src/commentcnv.l b/src/commentcnv.l
+index 8823b68..ff75b4d 100644
+--- a/src/commentcnv.l
++++ b/src/commentcnv.l
+@@ -1038,7 +1038,7 @@ void convertCppComments(BufStr *inBuf,BufStr *outBuf,const char *fileName)
+
+
+ //----------------------------------------------------------------------------
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void commentcnvYYdummy() { yy_flex_realloc(0,0); }
+ }
+diff --git a/src/commentscan.l b/src/commentscan.l
+index 3546277..c3746ab 100644
+--- a/src/commentscan.l
++++ b/src/commentscan.l
+@@ -1103,7 +1103,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
+ // but we need to know the position in the input buffer where this
+ // rule matched.
+ // for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
+-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
++#if (YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33) || YY_FLEX_MINOR_VERSION>5
+ inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf);
+ #else
+ inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf);
+@@ -1165,7 +1165,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
+ g_memberGroupHeader.resize(0);
+ parseMore=TRUE;
+ needNewEntry = TRUE;
+-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
++#if (YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33) || YY_FLEX_MINOR_VERSION>5
+ inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext);
+ #else
+ inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext);
+@@ -3202,7 +3202,7 @@ static void handleGuard(const QCString &expr)
+
+
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ //----------------------------------------------------------------------------
+ extern "C" { // some bogus code to keep the compiler happy
+ void commentscanYYdummy() { yy_flex_realloc(0,0); }
+diff --git a/src/declinfo.l b/src/declinfo.l
+index 0f24d9e..180fd01 100644
+--- a/src/declinfo.l
++++ b/src/declinfo.l
+@@ -352,7 +352,7 @@ int main()
+ }
+ #endif
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ //----------------------------------------------------------------------------
+ extern "C" { // some bogus code to keep the compiler happy
+ void declinfoYYdummy() { yy_flex_realloc(0,0); }
+diff --git a/src/defargs.l b/src/defargs.l
+index 9032d8e..f23055f 100644
+--- a/src/defargs.l
++++ b/src/defargs.l
+@@ -575,7 +575,7 @@ void stringToArgumentList(const char *argsString,ArgumentList* al,QCString *extr
+ printlex(yy_flex_debug, FALSE, __FILE__, NULL);
+ }
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void defargsYYdummy() { yy_flex_realloc(0,0); }
+ }
+diff --git a/src/doctokenizer.l b/src/doctokenizer.l
+index 31d583c..9f03108 100644
+--- a/src/doctokenizer.l
++++ b/src/doctokenizer.l
+@@ -1512,7 +1512,7 @@ void doctokenizerYYendAutoList()
+ // printlex(yy_flex_debug, FALSE, __FILE__, g_fileName);
+ // return retval;
+ //}
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void doctokenizerYYdummy() { yy_flex_realloc(0,0); }
+ }
+diff --git a/src/fortrancode.l b/src/fortrancode.l
+index af1a82e..da28dd5 100644
+--- a/src/fortrancode.l
++++ b/src/fortrancode.l
+@@ -1302,11 +1302,11 @@ void parseFortranCode(CodeOutputInterface &od,const char *className,const QCStri
+ return;
+ }
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void fortrancodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
+ #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
+ #else
+ extern "C" { // some bogus code to keep the compiler happy
+diff --git a/src/fortranscanner.l b/src/fortranscanner.l
+index cbe13fd..cda7913 100644
+--- a/src/fortranscanner.l
++++ b/src/fortranscanner.l
+@@ -2604,7 +2604,7 @@ static void scanner_abort()
+
+ //----------------------------------------------------------------------------
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ //----------------------------------------------------------------------------
+ extern "C" { // some bogus code to keep the compiler happy
+ void fortranscannernerYYdummy() { yy_flex_realloc(0,0); }
+diff --git a/src/pre.l b/src/pre.l
+index 86f9ebb..42acdca 100644
+--- a/src/pre.l
++++ b/src/pre.l
+@@ -3214,7 +3214,7 @@ void preprocessFile(const char *fileName,BufStr &input,BufStr &output)
+
+ void preFreeScanner()
+ {
+-#if defined(YY_FLEX_SUBMINOR_VERSION)
++#if defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ if (g_lexInit)
+ {
+ preYYlex_destroy();
+@@ -3222,7 +3222,7 @@ void preFreeScanner()
+ #endif
+ }
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ // int preYYwrap() { return 1 ; }
+ void preYYdummy() { yy_flex_realloc(0,0); }
+diff --git a/src/pycode.l b/src/pycode.l
+index 3c41a69..0a7590c 100644
+--- a/src/pycode.l
++++ b/src/pycode.l
+@@ -1499,11 +1499,11 @@ void parsePythonCode(CodeOutputInterface &od,const char * /*className*/,
+ }
+
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void pycodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
+ #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
+ #endif
+
+diff --git a/src/pyscanner.l b/src/pyscanner.l
+index 8332a36..a6c7e61 100644
+--- a/src/pyscanner.l
++++ b/src/pyscanner.l
+@@ -1745,7 +1745,7 @@ void PythonLanguageScanner::resetCodeParserState()
+
+ //----------------------------------------------------------------------------
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ //----------------------------------------------------------------------------
+ extern "C" { // some bogus code to keep the compiler happy
+ void pyscannerYYdummy() { yy_flex_realloc(0,0); }
+diff --git a/src/scanner.l b/src/scanner.l
+index 328dc3f..b29ce65 100644
+--- a/src/scanner.l
++++ b/src/scanner.l
+@@ -7076,7 +7076,7 @@ void CLanguageScanner::parsePrototype(const char *text)
+
+ //----------------------------------------------------------------------------
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ //----------------------------------------------------------------------------
+ extern "C" { // some bogus code to keep the compiler happy
+ void scannerYYdummy() { yy_flex_realloc(0,0); }
+diff --git a/src/tclscanner.l b/src/tclscanner.l
+index 5e249a6..d7b3243 100644
+--- a/src/tclscanner.l
++++ b/src/tclscanner.l
+@@ -3095,7 +3095,7 @@ void tclDummy()
+ yy_top_state();
+ }
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ //----------------------------------------------------------------------------
+ extern "C" { // some bogus code to keep the compiler happy
+ void tclscannerYYdummy() { yy_flex_realloc(0,0); }
+diff --git a/src/vhdlcode.l b/src/vhdlcode.l
+index 369ae48..418999e 100644
+--- a/src/vhdlcode.l
++++ b/src/vhdlcode.l
+@@ -1601,7 +1601,7 @@ void parseVhdlCode(CodeOutputInterface &od,const char *className,const QCString
+
+ void codeFreeVhdlScanner()
+ {
+-#if defined(YY_FLEX_SUBMINOR_VERSION)
++#if defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ if (g_lexInit)
+ {
+ vhdlcodeYYlex_destroy();
+@@ -1609,11 +1609,11 @@ void codeFreeVhdlScanner()
+ #endif
+ }
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
+ #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
+ #endif
+
+diff --git a/src/xmlcode.l b/src/xmlcode.l
+index 15b5d7e..e3646b5 100644
+--- a/src/xmlcode.l
++++ b/src/xmlcode.l
+@@ -403,11 +403,11 @@ void resetXmlCodeParserState()
+ g_currentMemberDef = 0;
+ }
+
+-#if !defined(YY_FLEX_SUBMINOR_VERSION)
++#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
+ extern "C" { // some bogus code to keep the compiler happy
+ void xmlcodeYYdummy() { yy_flex_realloc(0,0); }
+ }
+-#elif YY_FLEX_SUBMINOR_VERSION<33
++#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION<6
+ #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
+ #endif
+
+--
+2.6.4
+
diff --git a/PKGBUILD b/PKGBUILD
index 8ffcc7de3c8e..a2a7a07df43c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,27 @@
pkgname=doxyparse
_actual_ver=1.5.9
_extra_ver=20090622
+_relase=1899087a8b26293bec2c31e238098d968add7d0b
pkgver=${_actual_ver}_${_extra_ver}
-pkgrel=4
+pkgrel=5
pkgdesc="Parses source code and dumps the dependencies between the code elements."
groups=('analizo')
arch=('any')
url="http://analizo.org"
license=('GPLv2')
makedepends=('qt4' 'git' 'flex')
-source=("qtools.patch")
-sha512sums=('8095af5f6ba616864be6389b4245ab7a3a3723298635831c4f714468d6768cf86a382802ad8189053414f7701654ef683d1342936a31b98208ebf78f5e92485a')
+source=("0001-Fix-Flex-version-compilation-restriction.patch")
+sha512sums=('9c3f836ede511108d3af78d316854dc386a188f5a59add6d5e7df272abdaa4f93a2b2147617e2d46716065c51f149638977269a14ceef6fc12c02c7b3eac33e4')
build(){
cd "${srcdir}"
- git clone https://gitlab.com/analizo/doxyparse.git
- cp "${srcdir}/qtools.patch" doxyparse
+ git clone https://github.com/analizo/doxyparse.git
+ cp "${srcdir}/0001-Fix-Flex-version-compilation-restriction.patch" doxyparse
cd doxyparse
- git apply qtools.patch
- ./configure --with-doxyparse
+ git checkout "${release}"
+ git apply 0001-Fix-Flex-version-compilation-restriction.patch
+ cmake .
make
}
diff --git a/qtools.patch b/qtools.patch
deleted file mode 100644
index 0cef15cbf9f1..000000000000
--- a/qtools.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/qtools/qglobal.h b/qtools/qglobal.h
-index 5417861..b8c5067 100644
---- a/qtools/qglobal.h
-+++ b/qtools/qglobal.h
-@@ -86,7 +86,16 @@
- # if !defined(MAC_OS_X_VERSION_10_5)
- # define MAC_OS_X_VERSION_10_5 MAC_OS_X_VERSION_10_4 + 1
- # endif
--# if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_5)
-+# if !defined(MAC_OS_X_VERSION_10_6)
-+# define MAC_OS_X_VERSION_10_6 MAC_OS_X_VERSION_10_5 + 1
-+# endif
-+# if !defined(MAC_OS_X_VERSION_10_7)
-+# define MAC_OS_X_VERSION_10_7 MAC_OS_X_VERSION_10_6 + 1
-+# endif
-+# if !defined(MAC_OS_X_VERSION_10_8)
-+# define MAC_OS_X_VERSION_10_8 MAC_OS_X_VERSION_10_7 + 1
-+# endif
-+# if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_8)
- # error "This version of Mac OS X is unsupported"
- # endif
- #elif defined(MSDOS) || defined(_MSDOS) || defined(__MSDOS__)
-diff --git a/qtools/qvaluestack.h b/qtools/qvaluestack.h
-index 3fb61fd..fe4462a 100644
---- a/qtools/qvaluestack.h
-+++ b/qtools/qvaluestack.h
-@@ -49,7 +49,7 @@ class Q_EXPORT QValueStack : public QValueList<T>
- public:
- QValueStack() {}
- ~QValueStack() {}
-- void push( const T& d ) { append(d); }
-+ void push( const T& d ) { QValueList<T>::append(d); }
- T pop()
- {
- T elem( this->last() );