summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2015-06-08 21:55:34 -0300
committerRafael Reggiani Manzo2015-06-08 21:57:08 -0300
commitd83f6860566d0c06e13bb77f46a98268c58e0294 (patch)
tree5c627a3a29b6e9398e652d5fe137528067182151
downloadaur-d83f6860566d0c06e13bb77f46a98268c58e0294.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
-rw-r--r--qtools.patch35
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1123bc6213b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = doxyparse
+ pkgdesc = Parses source code and dumps the dependencies between the code elements.
+ pkgver = 1.5.9_20090622
+ pkgrel = 2
+ url = http://analizo.org
+ arch = any
+ groups = analizo
+ license = GPLv2
+ makedepends = qt4
+ makedepends = git
+ source = qtools.patch
+ sha512sums = 8095af5f6ba616864be6389b4245ab7a3a3723298635831c4f714468d6768cf86a382802ad8189053414f7701654ef683d1342936a31b98208ebf78f5e92485a
+
+pkgname = doxyparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..214d12bd9dec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+#PKGBUILD Maintainer: Rafael Reggiani Manzo <rr.manzo#gmail.com>
+
+pkgname=doxyparse
+_actual_ver=1.5.9
+_extra_ver=20090622
+pkgver=${_actual_ver}_${_extra_ver}
+pkgrel=2
+pkgdesc="Parses source code and dumps the dependencies between the code elements."
+groups=('analizo')
+arch=('any')
+url="http://analizo.org"
+license=('GPLv2')
+makedepends=('qt4' 'git')
+source=("qtools.patch")
+sha512sums=('8095af5f6ba616864be6389b4245ab7a3a3723298635831c4f714468d6768cf86a382802ad8189053414f7701654ef683d1342936a31b98208ebf78f5e92485a')
+
+build(){
+ cd "${srcdir}"
+
+ git clone git://gitorious.org/analizo/doxyparse.git
+ cp "${srcdir}/qtools.patch" doxyparse
+ cd doxyparse
+ git apply qtools.patch
+ ./configure --with-doxyparse
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+
+ make check || :
+}
+
+package(){
+ cd "${srcdir}/${pkgname}"
+
+ make DESTDIR="${pkgdir}/" install
+}
+
diff --git a/qtools.patch b/qtools.patch
new file mode 100644
index 000000000000..0cef15cbf9f1
--- /dev/null
+++ b/qtools.patch
@@ -0,0 +1,35 @@
+diff --git a/qtools/qglobal.h b/qtools/qglobal.h
+index 5417861..b8c5067 100644
+--- a/qtools/qglobal.h
++++ b/qtools/qglobal.h
+@@ -86,7 +86,16 @@
+ # if !defined(MAC_OS_X_VERSION_10_5)
+ # define MAC_OS_X_VERSION_10_5 MAC_OS_X_VERSION_10_4 + 1
+ # endif
+-# if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_5)
++# if !defined(MAC_OS_X_VERSION_10_6)
++# define MAC_OS_X_VERSION_10_6 MAC_OS_X_VERSION_10_5 + 1
++# endif
++# if !defined(MAC_OS_X_VERSION_10_7)
++# define MAC_OS_X_VERSION_10_7 MAC_OS_X_VERSION_10_6 + 1
++# endif
++# if !defined(MAC_OS_X_VERSION_10_8)
++# define MAC_OS_X_VERSION_10_8 MAC_OS_X_VERSION_10_7 + 1
++# endif
++# if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_8)
+ # error "This version of Mac OS X is unsupported"
+ # endif
+ #elif defined(MSDOS) || defined(_MSDOS) || defined(__MSDOS__)
+diff --git a/qtools/qvaluestack.h b/qtools/qvaluestack.h
+index 3fb61fd..fe4462a 100644
+--- a/qtools/qvaluestack.h
++++ b/qtools/qvaluestack.h
+@@ -49,7 +49,7 @@ class Q_EXPORT QValueStack : public QValueList<T>
+ public:
+ QValueStack() {}
+ ~QValueStack() {}
+- void push( const T& d ) { append(d); }
++ void push( const T& d ) { QValueList<T>::append(d); }
+ T pop()
+ {
+ T elem( this->last() );