summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2020-10-22 21:43:06 +0200
committerHans-Nikolai Viessmann2020-10-22 21:43:06 +0200
commit42e6ab25811db85d32f96a4fcb5a90f9c7fadbc0 (patch)
treefec098fc52ac76ebc501221c307a02d03d1d7eaf
downloadaur-42e6ab25811db85d32f96a4fcb5a90f9c7fadbc0.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD30
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd4eaf82325a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = doxypress-bin
+ pkgdesc = A fork of Doxygen, with improved output and support for clang parsing
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://www.copperspice.com/documentation-doxypress.html
+ arch = x86_64
+ license = GPL
+ depends = clang
+ depends = libxi
+ depends = fontconfig
+ depends = xcb-util-renderutil
+ depends = xcb-util-wm
+ depends = libxkbcommon-x11
+ depends = libglvnd
+ depends = libxrandr
+ depends = libxcursor
+ depends = xcb-util-keysyms
+ depends = libxinerama
+ depends = libsm
+ depends = xcb-util-image
+ provides = doxypress
+ conflicts = doxypress
+ replaces = doxypress
+ noextract = doxypress-1.4.0-arch-x64.tar.bz2
+ source = https://download.copperspice.com/doxypress/binary/doxypress-1.4.0-arch-x64.tar.bz2
+ sha512sums = 52d89ff0135648255332cda108ac32a3c4f1b6b2c5df382d5509b37635cad79c8b1e07e19a7727f708f6d3c81de4afa5f3fc5eaf923eee2811cd45721f26e9ba
+
+pkgname = doxypress-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc56c97d8857
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
+pkgname=doxypress-bin
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A fork of Doxygen, with improved output and support for clang parsing"
+arch=('x86_64')
+url="https://www.copperspice.com/documentation-doxypress.html"
+license=('GPL')
+depends=('clang' 'libxi' 'fontconfig' 'xcb-util-renderutil' 'xcb-util-wm' 'libxkbcommon-x11'
+ 'libglvnd' 'libxrandr' 'libxcursor' 'xcb-util-keysyms' 'libxinerama' 'libsm'
+ 'xcb-util-image')
+provides=('doxypress')
+conflicts=('doxypress')
+replaces=('doxypress')
+source=("https://download.copperspice.com/doxypress/binary/${pkgname%-bin}-${pkgver}-arch-x64.tar.bz2")
+sha512sums=('52d89ff0135648255332cda108ac32a3c4f1b6b2c5df382d5509b37635cad79c8b1e07e19a7727f708f6d3c81de4afa5f3fc5eaf923eee2811cd45721f26e9ba')
+noextract=("${pkgname%-bin}-${pkgver}-arch-x64.tar.bz2")
+
+package() {
+ cd "$srcdir"
+
+ # setup PATH through profile.d
+ install -d "${pkgdir}/etc/profile.d"
+ echo "export PATH=\$PATH:/opt/${pkgname%-bin}" > "${pkgdir}/etc/profile.d/${pkgname%-bin}.sh"
+ chmod +x "${pkgdir}/etc/profile.d/${pkgname%-bin}.sh"
+
+ # unpack the archive
+ install -d "${pkgdir}/opt/${pkgname%-bin}"
+ bsdtar --uname root --gname root -xf "${pkgname%-bin}-${pkgver}-arch-x64.tar.bz2" -C "${pkgdir}/opt/${pkgname%-bin}"
+}