summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-06-29 12:20:36 +0200
committerfelics2018-06-29 12:20:36 +0200
commit024556373da5835a0c759eb3526647b7dcbb7b2b (patch)
tree69b3322da245708f626d033e9b5505694813b9ac
downloadaur-024556373da5835a0c759eb3526647b7dcbb7b2b.tar.gz
Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c3b8b2499bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dpatch
+ pkgdesc = A easy to use patch system for Debian packages, somewhat similar to the dbs package, but much simpler to use.
+ pkgver = 2.0.38+nmu1
+ pkgrel = 1
+ url = http://packages.debian.org/unstable/dpatch
+ arch = any
+ license = GPL2
+ depends = debhelper
+ depends = dpkg
+ depends = perl
+ optdepends = fakeroot
+ optdepends = patchutils
+ optdepends = curl
+ noextract = dpatch_2.0.38+nmu1_all.deb
+ options = emptydirs
+ source = dpatch_2.0.38+nmu1_all.deb::http://http.debian.net/debian/pool/main/d/dpatch/dpatch_2.0.38+nmu1_all.deb
+ sha256sums = d31edd4f5e7f769b66aabb67cc76e5b6e4c10c64becd2d60dc18b6f3c95bda5a
+
+pkgname = dpatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fb4b2904453
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+#!/bin/bash
+
+pkgname=dpatch
+_pkgver="2.0.38"
+_deblevel="+nmu1"
+pkgver="${_pkgver}${_deblevel}"
+pkgrel=1
+
+pkgdesc="A easy to use patch system for Debian packages, somewhat similar to the dbs package, but much simpler to use."
+url="http://packages.debian.org/unstable/dpatch"
+license=('GPL2')
+
+arch=(
+ 'any'
+)
+
+depends=(
+ 'debhelper'
+ 'dpkg'
+ 'perl'
+)
+makedepends=()
+optdepends=(
+ 'fakeroot'
+ 'patchutils'
+ 'curl'
+)
+provides=()
+replaces=()
+conflicts=()
+
+options=('emptydirs')
+
+source=(
+ "dpatch_${_pkgver}${_deblevel}_all.deb::http://http.debian.net/debian/pool/main/d/dpatch/dpatch_${_pkgver}${_deblevel}_all.deb"
+)
+
+sha256sums=(
+ 'd31edd4f5e7f769b66aabb67cc76e5b6e4c10c64becd2d60dc18b6f3c95bda5a'
+)
+
+noextract=(
+ "dpatch_${_pkgver}${_deblevel}_all.deb"
+)
+
+package() {
+ cd "${srcdir}"
+ msg "Extracting files with dpkg-deb to \$pkgdir ..."
+ dpkg-deb -x "dpatch_${_pkgver}${_deblevel}_all.deb" "${pkgdir}"
+}