summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrocoDuck2017-05-14 14:31:59 +0100
committerCrocoDuck2017-05-14 14:31:59 +0100
commit49d0564baa835e06fba816d1e0395ebfb4832416 (patch)
treed8e0476f206074dbd37ef798458b54f0bbd890af
parent83ea9d4da7d18774251b19de38e269cf73c9e58f (diff)
downloadaur-49d0564baa835e06fba816d1e0395ebfb4832416.tar.gz
Update to r80.4477c3e
-rw-r--r--.SRCINFO6
-rw-r--r--LICENSE_KARS_ISC13
-rw-r--r--LICENSE_NDC_MIT20
-rw-r--r--PKGBUILD21
4 files changed, 8 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a6d28f08a1c..113cc6fac874 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpf-plugins-git
pkgdesc = Collection of DPF-based plugins by DISTRHO. LV2, LADSPA, dssi and VST.
- pkgver = r73.fe9e89e
+ pkgver = r80.4477c3e
pkgrel = 1
url = http://distrho.sourceforge.net/
arch = i686
@@ -16,11 +16,7 @@ pkgbase = dpf-plugins-git
provides = dpf-plugins
conflicts = dpf-plugins
source = dpf-plugins::git://github.com/DISTRHO/DPF-Plugins
- source = LICENSE_KARS_ISC
- source = LICENSE_NDC_MIT
md5sums = SKIP
- md5sums = 7b4d7947003bd60e5475fc61c6d014da
- md5sums = 89d28c0ce6f25d8f0c3c4b1d5b4f0da3
pkgname = dpf-plugins-git
diff --git a/LICENSE_KARS_ISC b/LICENSE_KARS_ISC
deleted file mode 100644
index 6ecc24c163d5..000000000000
--- a/LICENSE_KARS_ISC
+++ /dev/null
@@ -1,13 +0,0 @@
-DISTRHO Plugin Framework (DPF)
-Copyright (C) 2012-2014 Filipe Coelho <falktx@falktx.com>
-
-Permission to use, copy, modify, and/or distribute this software for any purpose with
-or without fee is hereby granted, provided that the above copyright notice and this
-permission notice appear in all copies.
-
-THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD
-TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN
-NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
-DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER
-IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
-CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/LICENSE_NDC_MIT b/LICENSE_NDC_MIT
deleted file mode 100644
index 51cc839af27b..000000000000
--- a/LICENSE_NDC_MIT
+++ /dev/null
@@ -1,20 +0,0 @@
-Copyright (C) 2004-2006 Niall Moody
-Copyright (C) 2015 Filipe Coelho
-
-Permission is hereby granted, free of charge, to any person obtaining a
-copy of this software and associated documentation files (the "Software"),
-to deal in the Software without restriction, including without limitation
-the rights to use, copy, modify, merge, publish, distribute, sublicense,
-and/or sell copies of the Software, and to permit persons to whom the
-Software is furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 24c535b3daf2..4bb2b6241e07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: CrocoDuck <crocoduck dot oducks at gmail dot com>
pkgname=dpf-plugins-git
-pkgver=r73.fe9e89e
+pkgver=r80.4477c3e
pkgrel=1
pkgdesc="Collection of DPF-based plugins by DISTRHO. LV2, LADSPA, dssi and VST."
arch=('i686' 'x86_64')
@@ -11,12 +11,8 @@ depends=('liblo' 'projectm')
makedepends=('git' 'wget')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git://github.com/DISTRHO/DPF-Plugins"
- "LICENSE_KARS_ISC"
- "LICENSE_NDC_MIT")
-md5sums=('SKIP'
- '7b4d7947003bd60e5475fc61c6d014da'
- '89d28c0ce6f25d8f0c3c4b1d5b4f0da3')
+source=("${pkgname%-*}::git://github.com/DISTRHO/DPF-Plugins")
+md5sums=('SKIP')
pkgver() {
cd "${pkgname%-*}"
@@ -25,16 +21,13 @@ pkgver() {
build() {
cd "${pkgname%-*}"
- make
+ make BUILD_DSSI=true BUILD_LV2=true BUILD_VST=true BUILD_JACK=true
}
package() {
- # Install the custom licenses:
- install -Dm 644 "LICENSE_NDC_MIT" "$pkgdir/usr/share/licenses/$pkgname/AmplitudeImposer/LICENSE"
- install -Dm 644 "LICENSE_NDC_MIT" "$pkgdir/usr/share/licenses/$pkgname/CycleShifter/LICENSE"
- install -Dm 644 "LICENSE_NDC_MIT" "$pkgdir/usr/share/licenses/$pkgname/SoulForce/LICENSE"
- install -Dm 644 "LICENSE_KARS_ISC" "$pkgdir/usr/share/licenses/$pkgname/Kars/LICENSE"
- # Install the package files:
cd "${pkgname%-*}"
+ # Install the custom license:
+ install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Install the package files:
make DESTDIR="$pkgdir/" PREFIX="/usr" install
}