summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrocoDuck2017-01-13 21:10:09 +0000
committerCrocoDuck2017-01-13 21:10:09 +0000
commitc7675b558e2c5e0b05b56aa3a7f88a482e2d60d3 (patch)
tree540671b79c36b9eb1b8e37d756e271600c671766
downloadaur-c7675b558e2c5e0b05b56aa3a7f88a482e2d60d3.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--LICENSE_KARS_ISC13
-rw-r--r--LICENSE_NDC_MIT20
-rw-r--r--PKGBUILD40
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43efcc4314d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = dpf-plugins-git
+ pkgdesc = Collection of DPF-based plugins
+ pkgver = r72.5f35525
+ pkgrel = 1
+ url = http://distrho.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = MIT
+ license = custom:ISC
+ makedepends = git
+ makedepends = wget
+ depends = liblo
+ depends = projectm
+ provides = dpf-plugins
+ conflicts = dpf-plugins
+ source = dpf-plugins::git://github.com/DISTRHO/DPF-Plugins
+ source = LICENSE_KARS_ISC
+ source = LICENSE_NDC_MIT
+ md5sums = SKIP
+ md5sums = 7b4d7947003bd60e5475fc61c6d014da
+ md5sums = 89d28c0ce6f25d8f0c3c4b1d5b4f0da3
+
+pkgname = dpf-plugins-git
+
diff --git a/LICENSE_KARS_ISC b/LICENSE_KARS_ISC
new file mode 100644
index 000000000000..6ecc24c163d5
--- /dev/null
+++ b/LICENSE_KARS_ISC
@@ -0,0 +1,13 @@
+DISTRHO Plugin Framework (DPF)
+Copyright (C) 2012-2014 Filipe Coelho <falktx@falktx.com>
+
+Permission to use, copy, modify, and/or distribute this software for any purpose with
+or without fee is hereby granted, provided that the above copyright notice and this
+permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD
+TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN
+NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
+DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER
+IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/LICENSE_NDC_MIT b/LICENSE_NDC_MIT
new file mode 100644
index 000000000000..51cc839af27b
--- /dev/null
+++ b/LICENSE_NDC_MIT
@@ -0,0 +1,20 @@
+Copyright (C) 2004-2006 Niall Moody
+Copyright (C) 2015 Filipe Coelho
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09d7ee13177c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: CrocoDuck <crocoduck dot oducks at gmail dot com>
+
+pkgname=dpf-plugins-git
+pkgver=r72.5f35525
+pkgrel=1
+pkgdesc="Collection of DPF-based plugins"
+arch=('i686' 'x86_64')
+url="http://distrho.sourceforge.net/"
+license=('GPL' 'LGPL' 'MIT' 'custom:ISC')
+depends=('liblo' 'projectm')
+makedepends=('git' 'wget')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname%-*}::git://github.com/DISTRHO/DPF-Plugins"
+ "LICENSE_KARS_ISC"
+ "LICENSE_NDC_MIT")
+md5sums=('SKIP'
+ '7b4d7947003bd60e5475fc61c6d014da'
+ '89d28c0ce6f25d8f0c3c4b1d5b4f0da3')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-*}"
+ make
+}
+
+package() {
+ # Install the custom licenses:
+ install -Dm 644 "LICENSE_NDC_MIT" "$pkgdir/usr/share/licenses/$pkgname/AmplitudeImposer/LICENSE"
+ install -Dm 644 "LICENSE_NDC_MIT" "$pkgdir/usr/share/licenses/$pkgname/CycleShifter/LICENSE"
+ install -Dm 644 "LICENSE_NDC_MIT" "$pkgdir/usr/share/licenses/$pkgname/SoulForce/LICENSE"
+ install -Dm 644 "LICENSE_KARS_ISC" "$pkgdir/usr/share/licenses/$pkgname/Kars/LICENSE"
+ # Install the package files:
+ cd "${pkgname%-*}"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+}