summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-28 15:24:24 -0500
committerLuis Martinez2023-03-28 15:25:29 -0500
commit2f936f84dbda80112d1ad0382ba2af6ef08b6dfe (patch)
tree41b254987e2b015b3772009f9e0a2b234b09d0e5
parente46adffb098a6db22abce238e6dbb889368626f7 (diff)
downloadaur-2f936f84dbda80112d1ad0382ba2af6ef08b6dfe.tar.gz
packaging update
-rw-r--r--.SRCINFO13
-rw-r--r--CHANGES33
-rw-r--r--PKGBUILD51
3 files changed, 68 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2620b5a648c8..0decb1277d3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = dpic
pkgdesc = A pic language interpreter.
pkgver = 2023.02.01
- pkgrel = 1
- url = http://www.ece.uwaterloo.ca/~aplevich/dpic/
- arch = i686
+ pkgrel = 2
+ url = https://ece.uwaterloo.ca/~aplevich/dpic
+ changelog = CHANGES
arch = x86_64
license = BSD
- source = https://ece.uwaterloo.ca/~aplevich/dpic/dpic-2023.02.01.tar.gz
+ source = dpic-2023.02.01.tar.gz::https://ece.uwaterloo.ca/~aplevich/dpic/dpic-2023.02.01.tar.gz
sha256sums = d059ff28c04552066c164fb146fee8e0101b953e46e75919b3dcfaa99b031ae6
pkgname = dpic
+ depends = glibc
+ optdepends = dpic-docs: Documentation for using dpic
+
+pkgname = dpic-docs
+ arch = any
diff --git a/CHANGES b/CHANGES
new file mode 100644
index 000000000000..718cfb6fbde1
--- /dev/null
+++ b/CHANGES
@@ -0,0 +1,33 @@
+
+2023 01 12 Distribution fix and cleanup.
+2022 12 01 More precise obtuse-angle arcs.
+2022 02 02 Minor addition to the manual.
+2021 11 01 Non-LaTeX error-handling cleanup.
+2021 08 01 Line thickness recovery parameter enabled.
+2021 05 15 Redundant code dating from pascal conversion removed.
+2021 05 12 Robustness fixes.
+2021 04 10 Improved robustness for fuzzed input.
+2021 01 01 Added colored svg sprintf text and % appended to selected outputs.
+2020 09 15 Shift operation bugfix.
+2020 09 01 Improved error messaging; additional distribution examples.
+2020 06 01 SVG text adjustments; GCC-10 conformance.
+2020 03 01 Commas protected by brackets; zero-repetition "for" loop bugfix
+ under bison.
+2019 11 30 Fix of environment variable scope, arc attribute; improved error
+ messages; generalized macro definition.
+2019 08 30 Debug fixes.
+2019 07 30 Corrected typos, copyright notices, version number, string treatment.
+2019 07 20 Bugfix for buffer overflow with extreme arguments of wfloat().
+2019 06 20 This is a major clone of the previous distribution, which
+ contained compilable C code together with the original pascal
+ source. The pascal was translated to C code using p2c,
+ which was included, and parsing was automated by a custom
+ compiler-compiler which was also provided. The current
+ package includes C source only with parsing automated using
+ GNU bison. The original lexical analyser has been kept. To
+ avoid introducing bugs, the C code has been changed only to
+ accommodate bison; some p2c idiosyncrasies remain. The result
+ is functionally identical to the previous version for correct
+ input.
+
+ A configure file (only needed for MinGW) added.
diff --git a/PKGBUILD b/PKGBUILD
index dd7813cbdbcd..d9cb49eefcaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: dreieck (https://aur.archlinux.org/account/dreieck)
# Contributor: Iru Cai <https://vimacs.wehack.space>
# Contributor: Pierpaolo Valerio
-pkgname=dpic
+pkgname=(dpic dpic-docs)
pkgver=2023.02.01
-pkgrel=1
+pkgrel=2
pkgdesc="A pic language interpreter."
-arch=(
- 'i686'
- 'x86_64'
-)
-url="http://www.ece.uwaterloo.ca/~aplevich/${pkgname}/"
-license=(
- 'BSD'
-)
-depends=()
-optdepends=()
-makedepends=()
-source=(
- "https://ece.uwaterloo.ca/~aplevich/${pkgname}/${pkgname}-${pkgver}.tar.gz"
-)
-sha256sums=(
- 'd059ff28c04552066c164fb146fee8e0101b953e46e75919b3dcfaa99b031ae6'
-)
+arch=('x86_64')
+url="https://ece.uwaterloo.ca/~aplevich/dpic"
+license=('BSD')
+changelog=CHANGES
+source=("$pkgname-$pkgver.tar.gz::$url/$pkgname-$pkgver.tar.gz")
+sha256sums=('d059ff28c04552066c164fb146fee8e0101b953e46e75919b3dcfaa99b031ae6')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make PREFIX=/usr
+ cd "$pkgname-$pkgver"
+ ./configure
+ make
}
-package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR=$pkgdir/usr install
-}
+package_dpic() {
+ depends=('glibc')
+ optdepends=('dpic-docs: Documentation for using dpic')
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/usr" installdpic
+ install -Dvm644 Copyright.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_dpic-docs() {
+ arch=('any')
+ cd "$pkgbase-$pkgver"
+ make DESTDIR="$pkgdir/usr" installdocs
+ install -Dvm644 Copyright.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}