summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2023-03-24 21:06:04 +0100
committeraksr2023-03-24 21:06:04 +0100
commit308c9b74b0cb15e4c7c92b9bde8059a936eb7c27 (patch)
tree8e025006d476c462dbf31832b1cc89fef1bf33d4
parent1cbd42561f462029a2fe6211f5f5176bb722030d (diff)
downloadaur-dpic-git.tar.gz
...
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD39
2 files changed, 14 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b59cc14fea4..a57080129e5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Jul 7 04:39:56 UTC 2018
pkgbase = dpic-git
pkgdesc = An implementation of the pic "little language," with support for LaTeX, PDF, SVG, Postscript, and xfig 3.2 output.
- pkgver = r20.3073b72
+ pkgver = r48.1e982f5
pkgrel = 1
url = https://ece.uwaterloo.ca/~aplevich/dpic/
arch = i686
arch = x86_64
- license = BSD
+ license = custom: BSD
makedepends = git
conflicts = dpic
source = dpic-git::git+https://gitlab.com/aplevich/dpic.git
md5sums = SKIP
pkgname = dpic-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7385c8da8154..2b37fdef7f6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,31 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=dpic-git
-pkgver=r20.3073b72
+pkgver=r48.1e982f5
pkgrel=1
-epoch=
-pkgdesc="An implementation of the pic \"little language,\" with support for LaTeX, PDF, SVG, Postscript, and xfig 3.2 output."
+pkgdesc='An implementation of the pic "little language," with support for LaTeX, PDF, SVG, Postscript, and xfig 3.2 output.'
arch=('i686' 'x86_64')
url="https://gitlab.com/aplevich/dpic.git"
url="https://ece.uwaterloo.ca/~aplevich/dpic/"
-license=('BSD')
-categories=()
-groups=()
-depends=()
+license=('custom: BSD')
makedepends=('git')
-optdepends=()
-checkdepends=()
-provides=()
conflicts=("${pkgname%-*}")
-replaces=()
-backup=()
-options=()
-changelog=
-install=
source=("$pkgname::git+https://gitlab.com/aplevich/dpic.git")
-noextract=()
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$pkgname"
- ./configure --prefix=/usr
- make
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/usr" install
- install -Dm644 README $pkgdir/usr/share/doc/${pkgname%-*}/README
- sed '145,171!d' README > LICENSE
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/usr" install
+ install -D -m644 README $pkgdir/usr/share/doc/${pkgname%-*}/README
+ install -D -m644 Copyright.txt $pkgdir/usr/share/licenses/${pkgname%-*}/Copyright
}
-