summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIdo Rosen2013-10-30 22:44:59 -0400
committerIdo Rosen2013-10-30 22:44:59 -0400
commitb22d5cadb70ef87022a50681fba322cdb83d21c9 (patch)
treefae58a67bf4069aa14d0347af1c88fcf6f5b42e4
downloadaur-b22d5cadb70ef87022a50681fba322cdb83d21c9.tar.gz
Moved all AUR packages into 'aur' directory.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD50
-rw-r--r--dpkg-gzip-rsyncable.patch11
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15bd85cceb83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = dpkg
+ pkgdesc = The Debian Package Manager. Don't use it instead of Arch's 'pacman'.
+ pkgver = 1.16.12
+ pkgrel = 1
+ url = http://packages.debian.org/dpkg
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = make
+ makedepends = perl
+ makedepends = pkg-config
+ makedepends = perl-io-string
+ makedepends = perl-timedate
+ depends = bzip2
+ depends = xz
+ depends = zlib
+ depends = ncurses
+ optdepends = fakeroot
+ conflicts = dpkg-ubuntu
+ replaces = dpkg-ubuntu
+ source = http://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_1.16.12.tar.xz
+ source = dpkg-gzip-rsyncable.patch
+ md5sums = b7e9cac52ff7882b088a3058b52081b5
+ md5sums = 5ab63758999e9bb10f84bce79a0307b2
+
+pkgname = dpkg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ceaa123b6d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jochen Schalanda <jochen+aur (at) schalanda.name>
+# Contributor: Pierre Carrier <pierre@spotify.com>
+# Contributor: Thomas Dziedzic <gostrc (at) gmail>
+# Contributor: Chris Giles <Chris.G.27 (at) Gmail.com>
+# Contributor: seblu <seblu+arch (at) seblu.net>
+# Contributor: squiddo <squiddo (at) intheocean.net>
+# Contributor: dront78 <dront78 (at) gmail.com>
+#
+# NOTE: To request changes to this package, please submit a pull request
+# to the GitHub repository at https://github.com/ido/packages-archlinux
+# Otherwise, open a GitHub issue. Thank you! -Ido
+#
+pkgname=dpkg
+pkgver=1.16.12
+pkgrel=1
+pkgdesc="The Debian Package Manager. Don't use it instead of Arch's 'pacman'."
+arch=('i686' 'x86_64')
+url="http://packages.debian.org/${pkgname}"
+license=('GPL')
+depends=('bzip2' 'xz' 'zlib' 'ncurses')
+makedepends=('gcc' 'make' 'perl' 'pkg-config' 'perl-io-string' 'perl-timedate')
+optdepends=('fakeroot')
+replaces=(dpkg-ubuntu)
+conflicts=(dpkg-ubuntu)
+source=(
+ http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz
+ dpkg-gzip-rsyncable.patch
+)
+md5sums=('b7e9cac52ff7882b088a3058b52081b5'
+ '5ab63758999e9bb10f84bce79a0307b2')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -p0 -i "${startdir}/dpkg-gzip-rsyncable.patch"
+
+ # Build
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin \
+ --disable-start-stop-daemon --disable-install-info --with-zlib --with-bz2 --with-liblzma
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Variables
+ install -d "${pkgdir}/var/${pkgname}/updates/"
+ touch ${pkgdir}/var/lib/${pkgname}/{status,available}
+}
diff --git a/dpkg-gzip-rsyncable.patch b/dpkg-gzip-rsyncable.patch
new file mode 100644
index 000000000000..3daf6d76ef60
--- /dev/null
+++ b/dpkg-gzip-rsyncable.patch
@@ -0,0 +1,11 @@
+--- ./scripts/Dpkg/Compression.pm.orig 2012-04-27 04:49:02.000000000 +0200
++++ ./scripts/Dpkg/Compression.pm 2012-05-27 22:23:18.530628795 +0200
+@@ -52,7 +52,7 @@
+ my $COMP = {
+ "gzip" => {
+ "file_ext" => "gz",
+- "comp_prog" => [ "gzip", "--no-name", "--rsyncable" ],
++ "comp_prog" => [ "gzip", "--no-name" ],
+ "decomp_prog" => [ "gunzip" ],
+ "default_level" => 9,
+ },