summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2016-09-04 20:44:48 +0200
committerAlad Wenter2016-09-04 20:44:48 +0200
commitcf1260d2f9d9f904dbc3367db39cf9becbb73fe1 (patch)
treeeadfce280bb4d54f3832457d3b02057f0a098c8b
parent53bd8b250f844f127b149811066661896accb71a (diff)
downloadaur-cf1260d2f9d9f904dbc3367db39cf9becbb73fe1.tar.gz
Update to 1.8.10
+ Drop packages in base-devel from depends + Remove --rsyncable patch, flag in gzip upstream + Use sha256sums to match .dsc
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
-rw-r--r--dpkg-gzip-rsyncable.patch11
3 files changed, 31 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04404c23e7b0..5667cfbbb36d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Sep 4 18:44:24 UTC 2016
pkgbase = dpkg
pkgdesc = The Debian Package Manager. Don't use it instead of Arch's 'pacman'.
- pkgver = 1.18.9
+ pkgver = 1.18.10
pkgrel = 1
url = http://packages.debian.org/dpkg
arch = i686
arch = x86_64
license = GPL
- makedepends = gcc
- makedepends = make
- makedepends = perl
- makedepends = pkg-config
makedepends = perl-io-string
makedepends = perl-timedate
- depends = bzip2
depends = xz
depends = zlib
- depends = ncurses
- optdepends = fakeroot
- conflicts = dpkg-ubuntu
- replaces = dpkg-ubuntu
- source = http://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_1.18.9.tar.xz
- source = dpkg-gzip-rsyncable.patch
- md5sums = 8a28f8cd4b85d10a8a23e6428dd41c41
- md5sums = 71fd0c244ca1fc7132c708022ca50ef0
+ depends = bzip2
+ depends = perl
+ source = http://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_1.18.10.tar.xz
+ source = http://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_1.18.10.dsc
+ sha256sums = 025524da41ba18b183ff11e388eb8686f7cc58ee835ed7d48bd159c46a8b6dc5
+ sha256sums = SKIP
pkgname = dpkg
diff --git a/PKGBUILD b/PKGBUILD
index 6d3d2d7ce5b7..56ba012344f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jochen Schalanda <jochen+aur (at) schalanda.name>
+# Maintainer: Alad Wenter <alad (at) archlinux.info>
+# Contributor: Jochen Schalanda <jochen+aur (at) schalanda.name>
# Contributor: C. Dominik Bódi <dominik.bodi@gmx.de>
# Contributor: Pierre Carrier <pierre@spotify.com>
# Contributor: Thomas Dziedzic <gostrc (at) gmail>
@@ -8,45 +9,37 @@
# Contributor: dront78 <dront78 (at) gmail.com>
# Contributor: hugelgupf <ckoch (at) cs.nmt.edu>
#
-# NOTE: To request changes to this package, please submit a pull request
-# to the GitHub repository at https://github.com/ido/packages-archlinux
-# Otherwise, open a GitHub issue. Thank you! -Ido
-#
pkgname=dpkg
-pkgver=1.18.9
+pkgver=1.18.10
pkgrel=1
pkgdesc="The Debian Package Manager. Don't use it instead of Arch's 'pacman'."
arch=('i686' 'x86_64')
-url="http://packages.debian.org/${pkgname}"
+url="http://packages.debian.org/dpkg"
license=('GPL')
-depends=('bzip2' 'xz' 'zlib' 'ncurses')
-makedepends=('gcc' 'make' 'perl' 'pkg-config' 'perl-io-string' 'perl-timedate')
-optdepends=('fakeroot')
-replaces=(dpkg-ubuntu)
-conflicts=(dpkg-ubuntu)
-source=(
- http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz
- dpkg-gzip-rsyncable.patch
-)
-md5sums=('8a28f8cd4b85d10a8a23e6428dd41c41'
- '71fd0c244ca1fc7132c708022ca50ef0')
+depends=('xz' 'zlib' 'bzip2' 'perl')
+makedepends=('perl-io-string' 'perl-timedate')
+source=("http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver"{.tar.xz,.dsc})
+sha256sums=('025524da41ba18b183ff11e388eb8686f7cc58ee835ed7d48bd159c46a8b6dc5'
+'SKIP')
build() {
- cd "${pkgname}-${pkgver}"
-
- patch -p0 -i "${startdir}/dpkg-gzip-rsyncable.patch"
+ cd "$pkgname-$pkgver"
- # Build
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin \
- --disable-start-stop-daemon --disable-install-info --with-zlib --with-bz2 --with-liblzma
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --disable-start-stop-daemon \
+ --disable-install-info \
+ --with-zlib \
+ --with-liblzma
make
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
- # Variables
- install -d "${pkgdir}/var/${pkgname}/updates/"
- touch ${pkgdir}/var/lib/${pkgname}/{status,available}
+ install -d "$pkgdir/var/$pkgname"/updates/
+ touch "${pkgdir}/var/lib/$pkgname"/{status,available}
}
diff --git a/dpkg-gzip-rsyncable.patch b/dpkg-gzip-rsyncable.patch
deleted file mode 100644
index d9ebfa5d1b17..000000000000
--- a/dpkg-gzip-rsyncable.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./scripts/Dpkg/Compression.pm.orig 2012-04-27 04:49:02.000000000 +0200
-+++ ./scripts/Dpkg/Compression.pm 2012-05-27 22:23:18.530628795 +0200
-@@ -53,7 +53,7 @@
- my $COMP = {
- gzip => {
- file_ext => 'gz',
-- comp_prog => [ 'gzip', '--no-name', '--rsyncable' ],
-+ comp_prog => [ 'gzip', '--no-name' ],
- decomp_prog => [ 'gunzip' ],
- default_level => 9,
- },