summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub 'Eremiell' Marek2022-09-05 01:03:04 +0200
committerJakub 'Eremiell' Marek2022-09-05 01:03:04 +0200
commit7854773531ab51c2497b83bf54791454197a3d7f (patch)
treeb7d891bdc7bbba7c559fffc2a6f8e36c71c4872e
parent380bbe3cf44832ed07b533a9f60bb2a376975962 (diff)
downloadaur-7854773531ab51c2497b83bf54791454197a3d7f.tar.gz
🔖 Update package, version 10.0.17-1
* Upstream version update * Snowflakes are now a full blown class * Experimental coroutine feature * Known reconnection issue * Various bugfixes * See upstream changelog for details
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--dpp.changelog12
-rw-r--r--dpp.install12
4 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0901023aaec8..79dfd24786e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.16
+ pkgver = 10.0.17
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -14,7 +14,7 @@ pkgbase = dpp
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.16.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.16.tar.gz
- sha256sums = dc99af06d9c2fdeefde534d99c00cbda4c96bac7d02ee68bcbbc2b47848bb28e
+ source = dpp-10.0.17.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.17.tar.gz
+ sha256sums = 7596dcc5602f756709f57d38c7f5b4c743cedb3d808416011ef0ab279cd5391e
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 819f6ab56f1b..d0850d776b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.16
+pkgver=10.0.17
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
@@ -13,7 +13,7 @@ makedepends=('cmake')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('dc99af06d9c2fdeefde534d99c00cbda4c96bac7d02ee68bcbbc2b47848bb28e')
+sha256sums=('7596dcc5602f756709f57d38c7f5b4c743cedb3d808416011ef0ab279cd5391e')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -30,7 +30,7 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
mkdir -p build
cd build
- cmake -DDPP_BUILD_TEST=OFF -DRUN_LDCONFIG=OFF -DDPP_NO_VCPKG=ON -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_MESSAGE=NEVER -Wno-dev ..
+ cmake -DDPP_BUILD_TEST=OFF -DRUN_LDCONFIG=OFF -DDPP_NO_VCPKG=ON -DDPP_CORO=ON -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_MESSAGE=NEVER -Wno-dev ..
make
}
diff --git a/dpp.changelog b/dpp.changelog
index 9a4185479cec..094afcc3225a 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,15 @@
+# 10.0.17-1 / 2022-09-05
+
+* bump to new library version
+ * snowflakes are now a full blown class
+ * experimental coroutines support
+ * this is not considered production ready
+ * any feedback is welcome on any official channels
+ * see library changelog for full list
+* this version has a known issue on reconnect
+ * you should be using 10.0.18 instead
+* late release for continuity
+
# 10.0.16-1 / 2022-08-18 (2022-09-04)
* bump to new library version
diff --git a/dpp.install b/dpp.install
index 60070346b077..3e8772b9e2ac 100644
--- a/dpp.install
+++ b/dpp.install
@@ -9,10 +9,22 @@ post_install() {
echo -e "\e[32mTo keep things lean and clean, embedded nlohmann/jsonhave been replaced by\e[0m"
echo -e "\e[32mpackaged version.\e[0m"
echo -e "\e[32mMind that when looking up online tutorials.\e[0m"
+ echo ""
+ echo -e "\e[32mPackage now includes experimental coroutine support.\e[0m"
+ echo -e "\e[32mIt's not considered production ready, but it's available for your experiments.\e[0m"
+ echo -e "\e[32mFeedback is welcome on any of the official channels.\e[0m"
+ echo ""
+ echo -e "\e[31mThis version has a known issue on reconnecting. You should be using 10.0.18 instead.\e[0m"
}
post_upgrade() {
echo -e "\e[1;33mEmbedded fmt have been completely dropped off the package.\e[0m"
echo -e "\e[1;33mWe already replaced that by systemwide version.\e[0m"
echo -e "\e[1;33mJust mind that it's not longer a dependency.\e[0m"
+ echo ""
+ echo -e "\e[32mPackage now includes experimental coroutine support.\e[0m"
+ echo -e "\e[32mIt's not considered production ready, but it's available for your experiments.\e[0m"
+ echo -e "\e[32mFeedback is welcome on any of the official channels.\e[0m"
+ echo ""
+ echo -e "\e[31mThis version has a known issue on reconnecting. You should be using 10.0.18 instead.\e[0m"
}