summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub 'Eremiell' Marek2023-01-08 19:32:25 +0100
committerJakub 'Eremiell' Marek2023-01-08 19:32:25 +0100
commitc4b496bf4b0e963a4cb324385e425a7134dfbfba (patch)
treea18bcc3138c785f4e72a5d97ebda2afffcb1a682
parente4cde4dc8b690c172ebaeec8edfaae69558d3d93 (diff)
downloadaur-c4b496bf4b0e963a4cb324385e425a7134dfbfba.tar.gz
🔖 Update package, version 10.0.22-1
* Upstream version update * CMake support has been fixed upstream * Support for various new small Discord features * Various bugfixes * See upstream changelog for details
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--dpp.changelog12
-rw-r--r--dpp.install27
4 files changed, 30 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991ac7b3ba7d..e803c4cf1fd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.21
+ pkgver = 10.0.22
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -15,7 +15,7 @@ pkgbase = dpp
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.21.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.21.tar.gz
- sha256sums = 8ef2bb75f16b80d742a99c3a18ab5a2a57bce74238518af9b9aca670c2d7034b
+ source = dpp-10.0.22.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.22.tar.gz
+ sha256sums = f8da36a9e24012fdff55a988e41d2015235b9e564b3151a1e5158fa1c7e05648
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index f171d7701b3f..d4a58f642749 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.21
+pkgver=10.0.22
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
@@ -13,15 +13,11 @@ makedepends=('cmake' 'pkgconf')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('8ef2bb75f16b80d742a99c3a18ab5a2a57bce74238518af9b9aca670c2d7034b')
+sha256sums=('f8da36a9e24012fdff55a988e41d2015235b9e564b3151a1e5158fa1c7e05648')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
find . \( -iname "*.h" -o -iname "*.cpp" \) -exec sed -i -E "s/dpp\/(nlohmann)\//\1\//" '{}' \+
- sed -i -E "s/install\(TARGETS dpp LIBRARY DESTINATION (.*)\)/install\(TARGETS dpp EXPORT dpp-targets LIBRARY DESTINATION \1\)\ninstall\(EXPORT dpp-targets DESTINATION \1\)/" "library/CMakeLists.txt"
- sed -i -E "s/libdpp/dpp/" "CMakeLists.txt" "cmake/libdpp-config.cmake"
- sed -i -E "s/libdpp-config/dpp-config/" "cmake/CPackSetup.cmake"
- mv "cmake/libdpp-config.cmake" "cmake/dpp-config.cmake"
sed -i -E "s/^.*dpp\/nlohmann.*$//" "library/CMakeLists.txt"
rm -rf "include/dpp/nlohmann"
}
@@ -37,12 +33,5 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}/" install
- rm -rf "${pkgdir}/usr/include/dpp-${pkgver%.*}"
- install -dm755 "${pkgdir}/usr/lib/cmake/${pkgname}/"
- find "${pkgdir}" -iname "*.cmake" -exec mv -t "${pkgdir}/usr/lib/cmake/${pkgname}" '{}' \+
- rm -rf "${pkgdir}/usr/lib/dpp-${pkgver%.*}/"
- find "${pkgdir}" -iname "*.cmake" -exec sed -i -E "s/\/dpp-${pkgver%.*}//g" '{}' \+
- sed -i -E "s/if\(_realCurr STREQUAL _realOrig\)/if\(1\)/" "${pkgdir}/usr/lib/cmake/dpp/dpp.cmake" "${pkgdir}/usr/lib/cmake/dpp/dpp-targets.cmake"
- sed -i -E "s/([ \(_]dpp)/\1::dpp/" "${pkgdir}/usr/lib/cmake/dpp/dpp-targets-noconfig.cmake"
ln -s "/usr/include/nlohmann" "${pkgdir}/usr/include/dpp/nlohmann"
}
diff --git a/dpp.changelog b/dpp.changelog
index 78198bbf6a57..cde4417a2965 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,15 @@
+# 10.0.22-1 / 2023-01-08
+
+* bump to new library version
+ * major cmake rehaul, fixes several longstanding issues
+ * support for various new small Discord features
+ * various fixes
+ * see library changelog for full list
+* changes to upstream cmake changed way we deal with that
+ * all cmake speific patches have been dropped
+ * find_package should now wor as intended
+ * pkg-config should continue to work as before
+
# 10.0.21-1 / 2022-11-02
* bump to new library version
diff --git a/dpp.install b/dpp.install
index 2e3baadd422e..082116ea8081 100644
--- a/dpp.install
+++ b/dpp.install
@@ -1,25 +1,24 @@
post_install() {
- echo -e "\e[31mNotice cmake find_package() doesn't currently work all the way.\e[0m"
- echo -e "\e[31mThis is a known upstream issue and will hopefully get fixed eventually.\e[0m"
- echo -e "\e[31mYou may want to use pkg-config to integrate into your cmake for now.\e[0m"
- echo ""
- echo -e "\e[1;33mAlso be aware one of the time conversion tests fail on devices not set to UTC.\e[0m"
- echo -e "\e[1;33mThis shouldn't affect your server deploys but may play role on your dev machine.\e[0m"
+ echo -e "\e[31mBe aware one of the time conversion tests fail on devices not set to UTC.\e[0m"
+ echo -e "\e[31mThis shouldn't affect your server deploys but may play role on your dev machine.\e[0m"
echo ""
echo -e "\e[32mTo keep things lean and clean, embedded nlohmann/json have been replaced by\e[0m"
echo -e "\e[32mpackaged version.\e[0m"
echo -e "\e[32mSymlink has been provided for convenience, but you may prefer to use it directly.\e[0m"
echo ""
- echo -e "\e[32mPackage now includes experimental coroutine support.\e[0m"
- echo -e "\e[32mIt's not considered production ready, but it's available for your experiments.\e[0m"
- echo -e "\e[32mFeedback is welcome on any of the official channels.\e[0m"
+ echo -e "\e[1;33mPackage now includes experimental coroutine support.\e[0m"
+ echo -e "\e[1;33mIt's not considered production ready, but it's available for your experiments.\e[0m"
+ echo -e "\e[1;33mFeedback is welcome on any of the official channels.\e[0m"
}
post_upgrade() {
- echo -e "\e[1;33mSymlink has been provided for the embedded nlohmann/json library.\e[0m"
- echo -e "\e[1;33mWe keep using the systemwide version. It's just for easier use of online tutorials.\e[0m"
+ echo -e "\e[31mCMake has been finally fixed. If you were using pkg-config up to now, nothing should\e[0m"
+ echo -e "\e[31mchange for you, but you an now also just use find_package and it should actually work.\e[0m"
+ echo ""
+ echo -e "\e[32mSymlink has been provided for the embedded nlohmann/json library.\e[0m"
+ echo -e "\e[32mWe keep using the systemwide version. It's just for easier use of online tutorials.\e[0m"
echo ""
- echo -e "\e[32mPackage now includes experimental coroutine support.\e[0m"
- echo -e "\e[32mIt's not considered production ready, but it's available for your experiments.\e[0m"
- echo -e "\e[32mFeedback is welcome on any of the official channels.\e[0m"
+ echo -e "\e[1;33mPackage now includes experimental coroutine support.\e[0m"
+ echo -e "\e[1;33mIt's not considered production ready, but it's available for your experiments.\e[0m"
+ echo -e "\e[1;33mFeedback is welcome on any of the official channels.\e[0m"
}