summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2020-08-16 11:39:14 +0700
committerkhai96_2020-08-16 11:39:14 +0700
commit7c9ef4343e2ffe8276d49f802dd407077d4a744e (patch)
tree05b222de339b9af439dc6cc59274e40a3f56cc20
parent1484ae92c34de0f267cca979b6140cdf0696b286 (diff)
downloadaur-7c9ef4343e2ffe8276d49f802dd407077d4a744e.tar.gz
Change PKGBUILD to install Dprint
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD41
2 files changed, 22 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01df2196a057..2367baf41339 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
-pkgbase = gnabel
- pkgdesc = A translation app for GTK environments based on Google Translate
- pkgver = 0.0.0
- pkgrel = 3
- url = https://github.com/gi-lom/gnabel
- arch = any
- license = GPL-3.0
- depends = python>=3
- depends = python-pyperclip
- depends = python-gobject
- depends = python-googletrans
- depends = python-gtts
- depends = python-pydub
- source = https://github.com/gi-lom/gnabel/archive/4559acb895d754ecd985dab686eb1acd7e5f37b4.zip
+pkgbase = dprint-bin
+ pkgdesc = Pluggable and configurable code formatting platform written in Rust.
+ pkgver = 0.9.0
+ pkgrel = 0
+ url = https://dprint.dev/
+ arch = x86_64
+ license = custom
+ source = https://github.com/dprint/dprint/releases/download/0.9.0/dprint-x86_64-unknown-linux-gnu.zip
+ source = https://github.com/dprint/dprint/raw/master/LICENSE
+ sha512sums = SKIP
sha512sums = SKIP
-pkgname = gnabel
+pkgname = dprint-bin
diff --git a/PKGBUILD b/PKGBUILD
index d1e60a33ad22..9dc338242ad8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,19 @@
# Maintainer: Hoàng Văn Khải <hvksmr1996@gmail.com>
-pkgname='gnabel'
-pkgver='0.0.0'
-pkgrel='3'
-pkgdesc='A translation app for GTK environments based on Google Translate'
-arch=('any')
-depends=(
- 'python>=3'
- 'python-pyperclip'
- 'python-gobject'
- 'python-googletrans' # aur only
- 'python-gtts' # aur only
- 'python-pydub' # aur only
-)
-url='https://github.com/gi-lom/gnabel'
-license=('GPL-3.0')
-_git_ref='4559acb895d754ecd985dab686eb1acd7e5f37b4'
+pkgname='dprint-bin'
+pkgver='0.9.0'
+pkgrel='0'
+pkgdesc='Pluggable and configurable code formatting platform written in Rust.'
+arch=('x86_64')
+url='https://dprint.dev/'
+license=('custom')
source=(
- "https://github.com/gi-lom/gnabel/archive/$_git_ref.zip"
+ "https://github.com/dprint/dprint/releases/download/$pkgver/dprint-x86_64-unknown-linux-gnu.zip"
+ 'https://github.com/dprint/dprint/raw/master/LICENSE'
)
-sha512sums=('SKIP')
+sha512sums=('SKIP' 'SKIP')
package() {
- cd "gnabel-$_git_ref"
-
- msg2 'Installing LICENSE'
+ install -Dm755 dprint "$pkgdir/usr/bin/dprint"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- msg2 'Installing executable'
- install -Dm755 gnabel.py "$pkgdir/usr/bin/gnabel"
-
- msg2 'Installing desktop file'
- install -Dm755 gnabel.desktop "$pkgdir/usr/share/applications/gnabel.desktop"
-
- msg2 'Installing icon'
- install -Dm644 icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/gnabel.svg"
}