summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Cao2019-06-24 08:11:33 +0800
committerNick Cao2019-06-24 08:11:33 +0800
commit3c34bac1f3904212ecc50dd291e0016f5b4d098b (patch)
treebcd9480d4abdd8073d9868b271b9af6f9851c8c5
parentedb948c12bcaad68a68e3ac9578b693ce309e711 (diff)
downloadaur-3c34bac1f3904212ecc50dd291e0016f5b4d098b.tar.gz
fix package issue
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..335ec9573de5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index b621fecf1ddb..49237fde4f71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer: Nick Cao <nickcao@nichi.co>
-pkgname='dptf'
-pkgver='8.4.10401'
-pkgrel=3
+pkgname=dptf
+pkgver=8.4.10401
+pkgrel=4
pkgdesc='Intel (R) Dynamic Platform and Thermal Framework (Intel (R) DPTF)'
arch=('x86_64')
url='https://github.com/intel/dptf'
license=('custom')
depends=('readline')
makedepends=('cmake')
-source=('https://github.com/intel/dptf/archive/8.4.10401.tar.gz')
-md5sums=('SKIP')
+source=('https://github.com/intel/dptf/archive/8.4.10401.tar.gz'
+ 'DPTF.patch'
+ 'ESIF_UF.patch'
+ )
+md5sums=('707632f2943e838f379d20a5076fb722'
+ '21d5ace7fd8bc7d16baa77695904a9d0'
+ '8d9cf347bc11bca7d0380ff35a5f5ebc')
prepare(){
mv $srcdir/dptf-8.4.10401 $srcdir/dptf
- patch $srcdir/dptf/DPTF/Linux/CMakeLists.txt ../DPTF.patch
- patch $srcdir/dptf/ESIF/Products/ESIF_UF/Linux/Makefile ../ESIF_UF.patch
+ patch $srcdir/dptf/DPTF/Linux/CMakeLists.txt $srcdir/DPTF.patch
+ patch $srcdir/dptf/ESIF/Products/ESIF_UF/Linux/Makefile $srcdir/ESIF_UF.patch
}
build() {
cd $srcdir/dptf/DPTF/Linux/build
cmake ..
- make -j`nproc`
+ make
cd $srcdir/dptf/ESIF/Products/ESIF_UF/Linux
make
cd $srcdir/dptf/ESIF/Products/ESIF_CMP/Linux