summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2019-10-17 12:35:22 +0200
committerHaochen Tong2019-10-17 12:35:22 +0200
commit958a236059f5b697a33fd32b50a650d1f5693a47 (patch)
treea94f1675e66f5f5b1c84f0098bd175ecbc0d9386
parent226fb1228ffea436f84f55f17ffbda692399d53e (diff)
downloadaur-958a236059f5b697a33fd32b50a650d1f5693a47.tar.gz
upgpkg
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d351e5d8667..55176733e966 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = dptf
pkgdesc = Intel (R) Dynamic Platform and Thermal Framework (Intel (R) DPTF)
- pkgver = 8.4.10401
- pkgrel = 5
+ pkgver = 8.7.10100
+ pkgrel = 1
url = https://github.com/intel/dptf
arch = x86_64
license = custom
makedepends = cmake
+ makedepends = ninja
depends = readline
- source = https://github.com/intel/dptf/archive/8.4.10401.tar.gz
- md5sums = 707632f2943e838f379d20a5076fb722
+ source = https://github.com/intel/dptf/archive/8.7.10100.tar.gz
+ sha256sums = fbd9302973fcb3ca32aec9a38891fa25e8ab17720fab3c994955fd1ffca72661
pkgname = dptf
diff --git a/PKGBUILD b/PKGBUILD
index 3f3d6584d202..344252fc46da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# Maintainer: Nick Cao <nickcao@nichi.co>
-# Maintainer: hexchain <richard0053@gmail.com>
pkgname=dptf
-pkgver=8.4.10401
-pkgrel=5
+pkgver=8.7.10100
+pkgrel=1
pkgdesc='Intel (R) Dynamic Platform and Thermal Framework (Intel (R) DPTF)'
arch=('x86_64')
url='https://github.com/intel/dptf'
license=('custom')
depends=('readline')
makedepends=('cmake')
-source=('https://github.com/intel/dptf/archive/8.4.10401.tar.gz')
-md5sums=('707632f2943e838f379d20a5076fb722')
+source=("https://github.com/intel/dptf/archive/$pkgver.tar.gz")
+sha256sums=('fbd9302973fcb3ca32aec9a38891fa25e8ab17720fab3c994955fd1ffca72661')
build() {
cd "$srcdir/$pkgname-$pkgver"
- export CXXFLAGS="${CXXFLAGS} -Wno-error=catch-value -Wno-error=stringop-truncation"
- export CFLAGS="${CFLAGS} -Wno-error=format-truncation"
+ export CXXFLAGS="${CXXFLAGS} -Wno-error=catch-value -Wno-error=stringop-truncation -ffile-prefix-map='$srcdir/$pkgname-$pkgver'="
+ export CFLAGS="${CFLAGS} -Wno-error=format-truncation -ffile-prefix-map='$srcdir/$pkgname-$pkgver'="
pushd DPTF/Linux/build
cmake ..
@@ -41,14 +39,11 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- install -Dm755 "DPTF/Linux/build/x64/release/Dptf.so" "$pkgdir/usr/share/dptf/ufx64/Dptf.so"
- install -Dm755 "DPTF/Linux/build/x64/release/DptfPolicyActive.so" "$pkgdir/usr/share/dptf/ufx64/DptfPolicyActive.so"
- install -Dm755 "DPTF/Linux/build/x64/release/DptfPolicyCritical.so" "$pkgdir/usr/share/dptf/ufx64/DptfPolicyCritical.so"
- install -Dm755 "DPTF/Linux/build/x64/release/DptfPolicyPassive.so" "$pkgdir/usr/share/dptf/ufx64/DptfPolicyPassive.so"
- install -Dm755 "ESIF/Products/ESIF_CMP/Linux/esif_cmp.so" "$pkgdir/usr/share/dptf/ufx64/esif_cmp.so"
- install -Dm755 "ESIF/Products/ESIF_WS/Linux/esif_ws.so" "$pkgdir/usr/share/dptf/ufx64/esif_ws.so"
- install -Dm644 "ESIF/Packages/DSP/dsp.dv" "$pkgdir/etc/dptf/dsp.dv"
- install -Dm755 "ESIF/Products/ESIF_UF/Linux/esif_ufd" "$pkgdir/usr/bin/esif_ufd"
- install -Dm644 "ESIF/Packages/Installers/linux/dptf.service" "$pkgdir/usr/lib/systemd/system/dptf.service"
- install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 DPTF/Linux/build/x64/release/Dptf{,Policy{Active,Critical,Passive}}.so -t "$pkgdir/usr/share/dptf/ufx64/"
+ install -Dm755 ESIF/Products/ESIF_CMP/Linux/esif_cmp.so "$pkgdir/usr/share/dptf/ufx64/esif_cmp.so"
+ install -Dm755 ESIF/Products/ESIF_WS/Linux/esif_ws.so "$pkgdir/usr/share/dptf/ufx64/esif_ws.so"
+ install -Dm644 ESIF/Packages/DSP/dsp.dv "$pkgdir/etc/dptf/dsp.dv"
+ install -Dm755 ESIF/Products/ESIF_UF/Linux/esif_ufd "$pkgdir/usr/bin/esif_ufd"
+ install -Dm644 ESIF/Packages/Installers/linux/dptf.service "$pkgdir/usr/lib/systemd/system/dptf.service"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}