summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Javorski2022-10-12 18:38:41 -0700
committerMike Javorski2022-10-12 18:38:41 -0700
commit617c7c7f0d53194974288410b01f6873675b0f94 (patch)
treeaf525b00b484c48c18f30deb2df7e8c3fe2b3425
parentaefb4765746161acf1995fa8f79cdf08c658f5d8 (diff)
downloadaur-617c7c7f0d53194974288410b01f6873675b0f94.tar.gz
Alter dependency used on dput startup to look for correct xdg distribution
Debian overrides the name of the pyxdg distribution and dput assumes this naming; Arch does not.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adb9f0ea2226..fcd592a60ae8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dput
pkgdesc = Debian package upload tool
pkgver = 1.1.2
- pkgrel = 2
+ pkgrel = 3
url = http://packages.qa.debian.org/dput
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index b6e0cb7974c3..573fc2823507 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Andre Klitzing <andre () incubo () de>
pkgname=dput
pkgver=1.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="Debian package upload tool"
arch=('any')
url="http://packages.qa.debian.org/dput"
@@ -15,6 +15,10 @@ md5sums=('21d77e7607cce37a42f7be38e5df8335')
build() {
cd "$pkgname-$pkgver"
+
+ # Adjust requirement, so that pyxdg is used when dput verifies dependencies (Debian overrrides the name of the pyxdg package instead)
+ sed -ri -e 's/"xdg"/"pyxdg"/' setup.py
+
python setup.py build
}