summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit097c90cdcfa21ceed05306033fca8b72304f70de (patch)
tree711429429620331095f7ec99412f7f37955a3154
downloadaur-097c90cdcfa21ceed05306033fca8b72304f70de.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD24
-rw-r--r--draci-historie-pl.install5
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08c0007ac154
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = draci-historie-pl
+ pkgdesc = The first Czech CD-ROM-based 2D point-and-click adventure game - polish version
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://www.ucw.cz/draci-historie/index-en.html
+ install = draci-historie-pl.install
+ arch = any
+ license = GPL2
+ depends = scummvm
+ optdepends = draci-historie-dubbing-cz: czech dubbing files for the game
+ conflicts = draci-historie-en
+ conflicts = draci-historie-cz
+ source = http://www.ucw.cz/draci-historie/binary/dh-pl.zip
+ md5sums = 5ffe3b709050b5f2c85aef5ea87e7591
+
+pkgname = draci-historie-pl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..1abbc8aa432b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=draci-historie-pl
+pkgver=1.0
+pkgrel=2
+pkgdesc="The first Czech CD-ROM-based 2D point-and-click adventure game - polish version"
+arch=('any')
+url="http://www.ucw.cz/draci-historie/index-en.html"
+license=('GPL2')
+depends=('scummvm')
+optdepends=('draci-historie-dubbing-cz: czech dubbing files for the game')
+conflicts=('draci-historie-en' 'draci-historie-cz')
+install=$pkgname.install
+source=(http://www.ucw.cz/draci-historie/binary/dh-pl.zip)
+md5sums=('5ffe3b709050b5f2c85aef5ea87e7591')
+
+package() {
+ cd ${srcdir}
+
+ install -d ${pkgdir}/usr/share/dragon_history
+ install -D -m644 ${srcdir}/* ${pkgdir}/usr/share/dragon_history
+
+ rm ${pkgdir}/usr/share/dragon_history/dh-pl.zip
+}
diff --git a/draci-historie-pl.install b/draci-historie-pl.install
new file mode 100644
index 000000000000..1c4a4e72f82e
--- /dev/null
+++ b/draci-historie-pl.install
@@ -0,0 +1,5 @@
+# arg 1: the new package version
+post_install() {
+ echo "=> To play the game, start scummvm, click on \"Add game\""
+ echo "=> and point it to /usr/share/dragon_history/ directory."
+}