summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-11-22 02:46:59 +0100
committerAlexandre Bouvier2022-11-22 02:46:59 +0100
commit479783bfe09661bbc4b216d731389a7d493f3f1e (patch)
tree37ac9c09ffd12f63849bca1661948fdd554964c6
downloadaur-479783bfe09661bbc4b216d731389a7d493f3f1e.tar.gz
update to r11.057d179
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f46210134c91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dracula-dircolors-git
+ pkgdesc = Dark theme for dircolors
+ pkgver = r11.057d179
+ pkgrel = 1
+ url = https://draculatheme.com/dircolors
+ arch = any
+ groups = dracula-theme
+ license = MIT
+ makedepends = git
+ optdepends = coreutils
+ provides = dracula-dircolors
+ conflicts = dracula-dircolors
+ source = dracula-dircolors::git+https://github.com/dracula/dircolors.git
+ b2sums = SKIP
+
+pkgname = dracula-dircolors-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ee2842acd3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+_pkgname=dracula-dircolors
+pkgname=$_pkgname-git
+pkgver=r11.057d179
+pkgrel=1
+pkgdesc="Dark theme for dircolors"
+arch=('any')
+url="https://draculatheme.com/dircolors"
+license=('MIT')
+groups=('dracula-theme')
+makedepends=('git')
+optdepends=('coreutils')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/dracula/dircolors.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_pkgname
+ # shellcheck disable=SC2154
+ install -Dm644 .dircolors "$pkgdir"/etc/DIR_COLORS.dracula
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}