summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDemonicSavage2023-01-26 14:16:05 -0300
committerDemonicSavage2023-01-26 14:16:05 -0300
commita0118c2fc6018fa3fd015a2aa89f05a5f1c23a37 (patch)
tree2884c60bcd046a5c6bb9298d03fbef346680ae63
downloadaur-a0118c2fc6018fa3fd015a2aa89f05a5f1c23a37.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31b373f71e33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dracula-kde-theme-git
+ pkgdesc = Dark theme for KDE (includes window decorations, color schemes, Plasma theme, cursor theme, Kvantum theme and SDDM theme)
+ pkgver = r297.a85f789
+ pkgrel = 1
+ url = https://github.com/dracula/gtk
+ arch = any
+ license = GPL
+ makedepends = git
+ optdepends = ttf-roboto: primary font face defined
+ optdepends = ttf-ubuntu-font-family: secondary font face defined
+ optdepends = cantarell-fonts: tertiary font face defined
+ provides = dracula-kde-theme
+ conflicts = dracula-kde-theme
+ source = dracula-kde-theme::git+https://github.com/dracula/gtk.git#branch=master
+ sha256sums = SKIP
+
+pkgname = dracula-kde-theme-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db86b2d76265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Gabriel Felipe Huwe <gabrielhuwe at gmail dot com>
+
+pkgname=dracula-kde-theme-git
+_pkgname=${pkgname%-git}
+_install_name=Dracula
+_branch=master
+pkgver=r297.a85f789
+pkgrel=1
+pkgdesc='Dark theme for KDE (includes window decorations, color schemes, Plasma theme, cursor theme, Kvantum theme and SDDM theme)'
+arch=('any')
+url='https://github.com/dracula/gtk'
+license=('GPL')
+makedepends=(git)
+optdepends=('ttf-roboto: primary font face defined'
+ 'ttf-ubuntu-font-family: secondary font face defined'
+ 'cantarell-fonts: tertiary font face defined')
+source=("$_pkgname::git+$url.git#branch=$_branch")
+sha256sums=('SKIP')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | \
+ sed 's/\([^-]*-g\)/r\1/;s/-/./g' || \
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/aurorae/themes"
+ cp -a "${srcdir}/${_pkgname}/kde/aurorae/"* "${pkgdir}/usr/share/aurorae/themes/"
+
+ mkdir -p "${pkgdir}/usr/share/color-schemes"
+ cp -a "${srcdir}/${_pkgname}/kde/color-schemes/"* "${pkgdir}/usr/share/color-schemes"
+
+ mkdir -p "${pkgdir}/usr/share/Kvantum"
+ cp -a "${srcdir}/${_pkgname}/kde/kvantum/"* "${pkgdir}/usr/share/Kvantum/"
+
+ mkdir -p "${pkgdir}/usr/share/plasma"
+ cp -a "${srcdir}/${_pkgname}/kde/plasma/"* "${pkgdir}/usr/share/plasma/"
+
+ mkdir -p "${pkgdir}/usr/share/sddm/themes"
+ cp -a "${srcdir}/${_pkgname}/kde/sddm/"* "${pkgdir}/usr/share/sddm/themes/"
+
+ mkdir -p "${pkgdir}/usr/share/icons/${_install_name}-cursors/"
+ cp -a "${srcdir}/${_pkgname}/kde/cursors/${_install_name}-cursors/"* "${pkgdir}/usr/share/icons/${_install_name}-cursors/"
+}