summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorallddd2023-08-08 19:07:17 +0200
committerallddd2023-08-08 19:07:17 +0200
commit7131267261460ae08348ccab7329414b835e8549 (patch)
tree849708d1572a08e38b503b18c85042fc891cbd55
downloadaur-7131267261460ae08348ccab7329414b835e8549.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
-rw-r--r--dracula-rofi-git.install7
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07c9570d17e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dracula-rofi-git
+ pkgdesc = Dark theme for Rofi
+ pkgver = r27.05618ac
+ pkgrel = 1
+ url = https://draculatheme.com/rofi
+ install = dracula-rofi-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ optdepends = rofi
+ source = dracula-rofi-git::git+https://github.com/dracula/rofi.git
+ sha256sums = SKIP
+
+pkgname = dracula-rofi-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc0850f72219
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!dracula-rofi-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4af9499c009b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Allddd <allddd (at) proton (dot) me>
+pkgname=dracula-rofi-git
+pkgver=r27.05618ac
+pkgrel=1
+pkgdesc='Dark theme for Rofi'
+arch=('any')
+url='https://draculatheme.com/rofi'
+license=('MIT')
+makedepends=('git')
+optdepends=('rofi')
+source=("${pkgname}::git+https://github.com/dracula/rofi.git")
+sha256sums=('SKIP')
+install=${pkgname}.install
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname}
+ list=$(find ./theme/ -type f -name '*.rasi')
+ for conf in ${list}; do
+ num=$(printf ${conf} | sed 's/[^0-9]*//g')
+ install -Dm644 "${conf}" "${pkgdir}/usr/share/rofi/themes/dracula${num}.rasi"
+ done
+}
diff --git a/dracula-rofi-git.install b/dracula-rofi-git.install
new file mode 100644
index 000000000000..5eb7d6c03962
--- /dev/null
+++ b/dracula-rofi-git.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo -e "\n\nTo preview and apply themes use: rofi-theme-selector \n\n"
+}
+
+post_upgrade() {
+ echo -e "\n\nTo preview and apply themes use: rofi-theme-selector \n\n"
+}