summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorallddd2023-12-30 11:50:01 +0100
committerallddd2023-12-30 11:50:01 +0100
commitac746a2ed77bc93339d329648870ffa5ef49f6c8 (patch)
tree0ac3e9b075256c89b3f5fb81c7e1d7e42c80d460
parent7131267261460ae08348ccab7329414b835e8549 (diff)
downloadaur-ac746a2ed77bc93339d329648870ffa5ef49f6c8.tar.gz
reformatted
-rw-r--r--PKGBUILD20
-rw-r--r--dracula-rofi-git.install6
2 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4af9499c009b..ed0c994b19ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Allddd <allddd (at) proton (dot) me>
+
pkgname=dracula-rofi-git
pkgver=r27.05618ac
pkgrel=1
@@ -13,15 +14,18 @@ sha256sums=('SKIP')
install=${pkgname}.install
pkgver() {
- cd ${pkgname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${pkgname}
- list=$(find ./theme/ -type f -name '*.rasi')
- for conf in ${list}; do
- num=$(printf ${conf} | sed 's/[^0-9]*//g')
- install -Dm644 "${conf}" "${pkgdir}/usr/share/rofi/themes/dracula${num}.rasi"
- done
+ cd ${pkgname}
+ num=1
+ list=$(find ./theme/ -type f -name '*.rasi')
+ for conf in ${list}; do
+ install -Dm644 "${conf}" "${pkgdir}/usr/share/rofi/themes/dracula${num}.rasi"
+ ((num++))
+ done
}
+
+# vim: ts=4 sw=4 et:
diff --git a/dracula-rofi-git.install b/dracula-rofi-git.install
index 5eb7d6c03962..9d4c0a84a6aa 100644
--- a/dracula-rofi-git.install
+++ b/dracula-rofi-git.install
@@ -1,7 +1,9 @@
post_install() {
- echo -e "\n\nTo preview and apply themes use: rofi-theme-selector \n\n"
+ echo -e "\nTo preview and apply themes use: rofi-theme-selector \n"
}
post_upgrade() {
- echo -e "\n\nTo preview and apply themes use: rofi-theme-selector \n\n"
+ post_install
}
+
+# vim: ts=4 sw=4 et: