summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaksim Fomin2019-10-27 18:58:18 +0000
committerMaksim Fomin2019-10-27 18:58:18 +0000
commit8546a1253ac23066b2843ca973ebbc358ec8dd14 (patch)
tree350c7e314734b624363b4280eabbbf383b0190c7
downloadaur-8546a1253ac23066b2843ca973ebbc358ec8dd14.tar.gz
Initial upload.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..401de1d561c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dracut-colors-git
+ pkgdesc = dracut hook to set VT console colors during early userspace
+ pkgver = 1.df81206
+ pkgrel = 1
+ url = https://github.com/mxfm/dracut-colors
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = dracut
+ depends = setcolors-git
+ source = dracut-colors-git::git://github.com/mxfm/dracut-colors
+ md5sums = SKIP
+
+pkgname = dracut-colors-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee9d46ba5820
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Maxim Fomin <maxim@fomin.one>
+
+_pkgname=dracut-colors
+pkgname=${_pkgname}-git
+pkgdesc="dracut hook to set VT console colors during early userspace"
+license=('MIT')
+url="https://github.com/mxfm/${_pkgname}"
+pkgver=1.df81206
+pkgrel=1
+
+source=("$pkgname::git://github.com/mxfm/${_pkgname}")
+md5sums=('SKIP')
+depends=('dracut' 'setcolors-git')
+makedepends=('git')
+arch=('any')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -Dm 644 hooks/module-setup.sh "${pkgdir}/usr/lib/dracut/modules.d/10colors/module-setup.sh"
+ install -Dm 644 hooks/setcolors.sh "${pkgdir}/usr/lib/dracut/modules.d/10colors/setcolors.sh"
+
+ install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}