summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-07-21 17:56:29 +0200
committerJonas Witschel2019-07-21 17:56:29 +0200
commit09777abf13452ce656b93028aebe403c62c8c139 (patch)
treef7bfd0bf1faf89a640f6c92f3e3ad63994965156
downloadaur-09777abf13452ce656b93028aebe403c62c8c139.tar.gz
Initial upload: dracut-git 049.r94.b6b1bf92-1
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD33
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5601f81b59f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = dracut-git
+ pkgdesc = An event driven initramfs infrastructure
+ pkgver = 049.r94.b6b1bf92
+ pkgrel = 1
+ url = https://dracut.wiki.kernel.org
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = asciidoc
+ depends = bash
+ depends = coreutils
+ depends = cpio
+ depends = filesystem
+ depends = findutils
+ depends = grep
+ depends = gzip
+ depends = kmod
+ depends = procps-ng
+ depends = sed
+ depends = systemd
+ depends = util-linux
+ depends = xz
+ provides = dracut
+ provides = initramfs
+ conflicts = dracut
+ backup = etc/dracut.conf
+ source = git+https://github.com/dracutdevs/dracut.git
+ sha512sums = SKIP
+
+pkgname = dracut-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfd4415117c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jonas Witschel <diabonas at gmx dot de>
+# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
+pkgname=dracut-git
+pkgver=049.r94.b6b1bf92
+pkgrel=1
+pkgdesc='An event driven initramfs infrastructure'
+arch=('x86_64')
+url='https://dracut.wiki.kernel.org'
+license=('GPL')
+depends=('bash' 'coreutils' 'cpio' 'filesystem' 'findutils' 'grep' 'gzip'
+ 'kmod' 'procps-ng' 'sed' 'systemd' 'util-linux' 'xz')
+makedepends=('git' 'asciidoc')
+provides=("${pkgname%-git}" 'initramfs')
+conflicts=("${pkgname%-git}")
+backup=('etc/dracut.conf')
+source=('git+https://github.com/dracutdevs/dracut.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ ./configure --prefix=/usr --sysconfdir=/etc --systemdsystemunitdir=/usr/lib/systemd/system
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
+}