summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-11-30 23:02:25 +0100
committerEric Engestrom2020-11-30 23:04:53 +0100
commit921934aa390bd4fa2e8802e620825a2c2d70f138 (patch)
tree6929f96ee35a045d4912fb3bb335e5378ae69aaf
downloadaur-921934aa390bd4fa2e8802e620825a2c2d70f138.tar.gz
initial commit - v4.2.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93c619eed4ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dragonframe-bin
+ pkgdesc = Industry standard stop motion animation software
+ pkgver = 4.2.2
+ pkgrel = 1
+ url = https://www.dragonframe.com/
+ arch = x86_64
+ license = EULA
+ depends = libudev0-shim
+ provides = dragonframe
+ conflicts = dragonframe
+ options = !strip
+ source = https://www.dragonframe.com/download/dragonframe4_4.2.2_amd64.deb
+ sha256sums = b594ed0a08900c08c759efe10244be9b3ec72ec136035a34bab6e31fbd89700c
+
+pkgname = dragonframe-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53ed6cdc31a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Eric Engestrom <arch.aur@engestrom.ch>
+
+pkgname=dragonframe-bin
+pkgver=4.2.2
+pkgrel=1
+pkgdesc="Industry standard stop motion animation software"
+arch=('x86_64')
+url=https://www.dragonframe.com/
+license=('EULA')
+provides=('dragonframe')
+conflicts=('dragonframe')
+source=("https://www.dragonframe.com/download/dragonframe4_${pkgver}_amd64.deb")
+sha256sums=('b594ed0a08900c08c759efe10244be9b3ec72ec136035a34bab6e31fbd89700c')
+options=('!strip')
+depends=('libudev0-shim')
+
+package() {
+ bsdtar xf "dragonframe4_${pkgver}_amd64.deb"
+ bsdtar xf data.tar.xz -C "$pkgdir"
+
+ # Placeholder file for the user's license
+ install -dm 755 "$pkgdir"/etc/opt/dragonframe4
+ echo "# License File" > "$pkgdir"/etc/opt/dragonframe4/license.properties
+ chmod 666 "$pkgdir"/etc/opt/dragonframe4/license.properties
+}