summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitf86a3fe09c1693ed9bcd5b57bec5f82d733b73de (patch)
treea8196a63e53624b285da699b46ea14156361ff38
downloadaur-f86a3fe09c1693ed9bcd5b57bec5f82d733b73de.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--drascula.sh3
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e597474bb76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = drascula
+ pkgdesc = "Drascula: The Vampire Strikes Back", classic comical 2D point & click adventure
+ pkgver = 1.0
+ pkgrel = 5
+ url = http://scummvm.sourceforge.net/
+ arch = any
+ license = custom
+ depends = scummvm>=1.0.0
+ optdepends = drascula-audio: audio files
+ optdepends = drascula-audio-flac: lossless audio files
+ optdepends = drascula-audio-mp3: mp3 audio files
+ source = http://downloads.sourceforge.net/scummvm/drascula-1.0.zip
+ source = drascula.sh
+ md5sums = fe2ee0948159c3acb923c89a1af7cc84
+ md5sums = 52b843b9acce56eaf8a84ebe83ed0a40
+
+pkgname = drascula
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b795b65bfb24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: rabyte <rabyte__gmail>
+
+pkgname=drascula
+pkgver=1.0
+pkgrel=5
+pkgdesc='"Drascula: The Vampire Strikes Back", classic comical 2D point & click adventure'
+arch=('any')
+url="http://scummvm.sourceforge.net/"
+license=('custom')
+depends=('scummvm>=1.0.0')
+optdepends=('drascula-audio: audio files'
+ 'drascula-audio-flac: lossless audio files'
+ 'drascula-audio-mp3: mp3 audio files')
+source=(http://downloads.sourceforge.net/scummvm/$pkgname-$pkgver.zip
+ $pkgname.sh)
+md5sums=('fe2ee0948159c3acb923c89a1af7cc84'
+ '52b843b9acce56eaf8a84ebe83ed0a40')
+
+package() {
+ cd "${srcdir}"
+
+ install -d "${pkgdir}"/usr/share/$pkgname/
+ install -m644 Packet.001 drascula.doc "${pkgdir}"/usr/share/$pkgname/
+ install -D -m644 readme.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+
+ install -D -m755 $pkgname.sh "${pkgdir}"/usr/bin/$pkgname
+}
diff --git a/drascula.sh b/drascula.sh
new file mode 100644
index 000000000000..6a71387a8223
--- /dev/null
+++ b/drascula.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/bin/scummvm "$@" -f -p /usr/share/drascula drascula