summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-03-31 12:32:42 +0200
committerPhilip Goto2019-03-31 12:32:42 +0200
commit455a95900d6dc36782dc5cb96a0e748e9fa4b201 (patch)
tree970b3c1a7913b6505a0cc2f3668f6e6fc15687e8
parent3426fe4c89194c4818ce04c8bc23cecb4d162739 (diff)
downloadaur-455a95900d6dc36782dc5cb96a0e748e9fa4b201.tar.gz
Simplify versioning
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fa313d1d3cc..25465a498e32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = drawing-git
pkgdesc = Drawing application for the GNOME desktop
- pkgver = r134.b748831
+ pkgver = 0.2.r4.g3f49a0e
pkgrel = 1
url = https://github.com/maoschanz/drawing
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 75fbe90c07bd..2a55309ebee9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=drawing-git
-pkgver=r134.b748831
+pkgver=0.2.r4.g3f49a0e
pkgrel=1
pkgdesc="Drawing application for the GNOME desktop"
url="https://github.com/maoschanz/drawing"
@@ -15,22 +15,19 @@ source=("git+https://github.com/maoschanz/drawing.git")
sha256sums=(SKIP)
pkgver() {
- cd drawing
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd drawing
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson drawing build
- ninja -C build
+ arch-meson drawing build
+ ninja -C build
}
#check() {
-# meson test -C build
+# meson test -C build
#}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
}