summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Valter2020-01-09 10:29:00 +0300
committerDmitry Valter2020-01-09 10:29:30 +0300
commitf3a91a031fedb0d4727c2c078bc281a0b957e6a3 (patch)
treeb0d5a601b9b080e1f3df14b0cd917107dbee987c
parent0871a6d55325fd42e4e50efaacc1a82d393252b5 (diff)
downloadaur-f3a91a031fedb0d4727c2c078bc281a0b957e6a3.tar.gz
Use yarn instead of npm
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 151614c7e8cd..38c6ef577e3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('x86_64')
url='https://github.com/jgraph/drawio'
license=('Apache')
depends=(electron gconf libnotify)
-makedepends=(npm ant)
+makedepends=(yarn ant)
source=("https://github.com/jgraph/drawio/archive/v$pkgver.tar.gz")
sha256sums=('c5d0c6aba4bb93bad5e283b3e3ea49b24f0b8d8b6578eade0013c62b6ccca25c')
@@ -27,15 +27,19 @@ build() {
# fix version in package.json
sed -i 's/"version": ".*"/"version": "'"$pkgver"'"/g' package.json
- npm install --cache ../npm-cache --only=production
-
+ yarn install --cache-folder ../npm-cache --prod
+ yarn autoclean -I
+ yarn autoclean -F
# remove paths refering build directories
find . -name 'package.json' -exec sed "s,$srcdir/src/drawio-$pkgver/src/main/webapp,/usr/lib/drawio,g" -i {} \;
rm -f 'package-lock.json'
+ find . -name '.yarnclean' -exec rm -fv {} \;
+ find . -name 'yarn.lock' -exec rm -fv {} \;
find . -name '.airtap.yml' -exec rm -fv {} \;
find . -name '.bin' -exec rm -fvr {} +
+ find . -name 'well-known' -exec rm -fvr {} +
find . -name '.coveralls.yml' -exec rm -fv {} \;
find . -name '.gitignore' -exec rm -fv {} \;
find . -name '.github' -exec rm -fvr {} +