summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb00rt00s2015-06-08 22:09:58 +0200
committerb00rt00s2015-06-08 22:09:58 +0200
commit1a7db74d258205d791a76066e1b56ef10ca60de4 (patch)
treef31fd3f39d72adc1cd369cd14ef7a2c197b2d189
downloadaur-1a7db74d258205d791a76066e1b56ef10ca60de4.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD67
-rw-r--r--drawxtl.desktop12
-rw-r--r--makefile.patch56
4 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bda1db9e2a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 8 19:31:06 UTC 2015
+pkgbase = drawxtl
+ pkgdesc = Crystal structure visualization tool
+ pkgver = 5.5
+ pkgrel = 2
+ url = http://www.lwfinger.net/drawxtl/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc
+ depends = fltk
+ depends = fontconfig
+ depends = glibc
+ depends = libxpm
+ depends = libxft
+ depends = mesa
+ depends = libgl
+ depends = libxinerama
+ depends = libxext
+ depends = libx11
+ provides = DRAWxtl
+ source = http://www.lwfinger.com/drawxtl/DRAWxtl55.tar.gz
+ source = makefile.patch
+ source = drawxtl.desktop
+ md5sums = c8323695b152a1b5e58ddf8ccb324a06
+ md5sums = bad81010282ace325011ed0493160000
+ md5sums = 032e6a9a0926693fae487eded91b9c21
+
+pkgname = drawxtl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf051e0d6133
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: b00rt00s ( bomby dot zrzuc at gmail dot com )
+pkgname=drawxtl
+pkgver=5.5
+pkgrel=2
+pkgdesc="Crystal structure visualization tool"
+arch=('i686' 'x86_64')
+url="http://www.lwfinger.net/drawxtl/"
+provides=('DRAWxtl')
+depends=('fltk' 'fontconfig' 'glibc' 'libxpm' 'libxft' 'mesa' 'libgl' 'libxinerama' 'libxext' 'libx11')
+
+makedepends=('gcc')
+license=('GPL2')
+#install=${pkgname}.install
+source=(
+ "http://www.lwfinger.com/drawxtl/DRAWxtl55.tar.gz"
+ "makefile.patch"
+ "drawxtl.desktop"
+)
+
+md5sums=(
+ 'c8323695b152a1b5e58ddf8ccb324a06'
+ 'bad81010282ace325011ed0493160000'
+ '032e6a9a0926693fae487eded91b9c21'
+)
+
+build() {
+cd ${srcdir}/DRAWxtl/source/DRAWxtl55/
+
+patch -p0 -i ../../../makefile.patch || return 1
+make || return 1
+}
+
+
+package() {
+#installing an executable
+mkdir -p ${pkgdir}/usr/bin
+install -D -m655 ${srcdir}/DRAWxtl/exe/DRAWxtl55 ${pkgdir}/usr/bin/DRAWxtl55
+cd ${pkgdir}/usr/bin
+ln -sf DRAWxtl55 drawxtl
+
+#installing COPYING file
+install -D -m644 ${srcdir}/DRAWxtl/source/DRAWxtl55/COPYING ${pkgdir}/usr/share/doc/drawxtl/COPYING
+
+#installing pixmap
+mkdir -p ${pkgdir}/usr/share/pixmaps
+install -D -m644 ${srcdir}/DRAWxtl/source/DRAWxtl55/DRAWxtl.xpm ${pkgdir}/usr/share/pixmaps/drawxtl.xpm
+
+#installing docs
+mkdir -p ${pkgdir}/usr/share/doc/drawxtl
+
+cd ${srcdir}/DRAWxtl/docs
+for i in *; do
+ install -D -m644 ${i} ${pkgdir}/usr/share/doc/drawxtl/${i}
+ gzip -9 ${pkgdir}/usr/share/doc/drawxtl/${i}
+done
+
+#installing examples
+mkdir -p ${pkgdir}/usr/share/doc/drawxtl/examples
+cd ${srcdir}/DRAWxtl/examples
+for i in *; do
+ install -D -m644 ${i} ${pkgdir}/usr/share/doc/drawxtl/examples/${i}
+done
+
+#installing drawxtl.desktop file
+install -D -m644 ${srcdir}/drawxtl.desktop ${pkgdir}/usr/share/applications/drawxtl.desktop
+}
+
diff --git a/drawxtl.desktop b/drawxtl.desktop
new file mode 100644
index 000000000000..3b252c228e34
--- /dev/null
+++ b/drawxtl.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=5.5
+Name=DRAWxtl
+Type=Application
+Terminal=false
+GenericName=Crystal structure visualization tool
+Comment=Display crystal structures
+Exec=drawxtl
+Icon=drawxtl
+Categories=Science
+MimeType=chemical/x-cif;chemical/x-shelx;
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..38f7787a2fea
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,56 @@
+*** origMakefile 2011-03-08 19:55:26.000000000 +0100
+--- Makefile 2012-05-18 19:04:04.412722880 +0200
+***************
+*** 32,44 ****
+
+ # section to define the various symbols needed to build DRAWxtl for Linux systems
+
+! prefix = /usr/local
+ includedir = ${prefix}/include
+ libdir = /usr/lib/
+
+ BUILD_CPU=$(shell uname -m)
+ ifneq (,$(findstring 64,$(BUILD_CPU)))
+! libdir = /usr/lib64/
+ endif
+
+ # compiler name:
+--- 32,44 ----
+
+ # section to define the various symbols needed to build DRAWxtl for Linux systems
+
+! prefix = /usr/
+ includedir = ${prefix}/include
+ libdir = /usr/lib/
+
+ BUILD_CPU=$(shell uname -m)
+ ifneq (,$(findstring 64,$(BUILD_CPU)))
+! libdir = /usr/lib/
+ endif
+
+ # compiler name:
+***************
+*** 49,59 ****
+ # work around a bug in freeglut 2.4 - only enable this if you have to use a version
+ # of fltk before 1.1.8 AND exactly version 2.4 of freeglut
+ # GLUT = -DFREEGLUT24
+! CXXFLAGS = $(OPTIM) -I/usr/X11R6/include $(GLUT)
+
+ # libraries to link with:
+! GLDLIBS = -L/usr/X11R6/lib -lGLU -lGL -lXinerama -lXft -lpthread -lm -lXext -lX11 -lXpm \
+! -lfltk \
+ # -lglut # only needed with old versions of fltk before 1.1.8
+ # -lXi -lgdkglext-x11-1.0a # Fedora Core 2 needs these libraries
+ LINKFLTKGL = $(libdir)libfltk.a $(libdir)libfltk_gl.a
+--- 49,59 ----
+ # work around a bug in freeglut 2.4 - only enable this if you have to use a version
+ # of fltk before 1.1.8 AND exactly version 2.4 of freeglut
+ # GLUT = -DFREEGLUT24
+! CXXFLAGS = $(OPTIM) $(GLUT)
+
+ # libraries to link with:
+! GLDLIBS = -lGLU -lGL -lXinerama -lXft -lpthread -lm -lXext -lX11 -lXpm \
+! -lfltk -ldl -lfontconfig\
+ # -lglut # only needed with old versions of fltk before 1.1.8
+ # -lXi -lgdkglext-x11-1.0a # Fedora Core 2 needs these libraries
+ LINKFLTKGL = $(libdir)libfltk.a $(libdir)libfltk_gl.a