summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRene Peinthor2018-04-25 13:57:25 +0200
committerRene Peinthor2018-04-25 13:57:25 +0200
commit893d8daafeb918b964d57083eedf8477b5e2cabd (patch)
tree91b54172e50e92ec8b89632ab094828c5d4e7c83
downloadaur-893d8daafeb918b964d57083eedf8477b5e2cabd.tar.gz
initial drbd-utils-git package
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD61
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b65d24342a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = drbd-utils-git
+ pkgdesc = Userland tools for Distributed Replicated Block Device
+ pkgver = 9.3.1
+ pkgrel = 1
+ url = https://www.drbd.org
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = libxslt
+ makedepends = systemd
+ depends = perl
+ depends = bash
+ provides = drbd-utils=${pkgver}
+ conflicts = drbd-utils
+ replaces = drbd-utils
+ backup = etc/drbd.conf
+ backup = etc/drbd.d/global_common.conf
+ source = git+https://github.com/LINBIT/drbd-utils.git
+ md5sums = SKIP
+
+pkgname = drbd-utils-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78d0fc672363
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+drbd-utils/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b9689a70f5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Rene Peinthor <peinthor@gmail.com>
+
+pkgname=drbd-utils-git
+pkgver=9.3.1
+pkgrel=1
+arch=('x86_64')
+pkgdesc='Userland tools for Distributed Replicated Block Device'
+url='https://www.drbd.org'
+license=('GPL2')
+depends=('perl' 'bash')
+makedepends=('git' 'libxslt' 'systemd')
+provides=('drbd-utils=${pkgver}')
+conflicts=('drbd-utils')
+replaces=('drbd-utils')
+source=("git+https://github.com/LINBIT/drbd-utils.git")
+backup=('etc/drbd.conf' 'etc/drbd.d/global_common.conf')
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/drbd-utils
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --with-distro=generic \
+ --with-bashcompletion \
+ --with-initscripttype=systemd \
+ --with-udev \
+ --without-rgmanager \
+ --without-pacemaker \
+ --without-heartbeat \
+ --without-83support \
+ --without-xen
+ make
+}
+
+package() {
+ make -C $srcdir/drbd-utils DESTDIR="$pkgdir" install
+
+ cd "$pkgdir"
+
+ # move /lib files under /usr/lib
+ mv lib/drbd/* usr/lib/drbd
+ rmdir lib/drbd lib
+
+ # move bash completion
+ install -dm 755 usr/share/bash-completion
+ mv etc/bash_completion.d usr/share/bash-completion/completions
+
+ # remove /var/lock
+ rmdir var/lock
+
+ # autoload module
+ install -Dm 644 /dev/null usr/lib/modules-load.d/drbd.conf
+ echo 'drbd' > usr/lib/modules-load.d/drbd.conf
+}
+
+# vim:set ts=2 sw=2 et: