summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Dübel2019-07-25 20:39:08 +0200
committerJakob Dübel2019-07-25 21:00:10 +0200
commit53a5355316138c4cc8608288043085fb62a527cf (patch)
tree0a5445a06890f8f55e359a4d90a0036e787f5169
parent112aef6bc54302f5161ba923056a57e69cf1859a (diff)
downloadaur-53a5355316138c4cc8608288043085fb62a527cf.tar.gz
Update version and remove obsolete patch.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--drc.diff55
3 files changed, 6 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b6192631a3b..1723015d6db9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = drc
pkgdesc = Digital Room Correction FIR filter generator
- pkgver = 3.2.2
+ pkgver = 3.2.3
pkgrel = 1
url = http://drc-fir.sourceforge.net/
arch = x86_64
@@ -8,10 +8,8 @@ pkgbase = drc
license = GPL2
depends = gcc-libs
optdepends = octave: building graphs
- source = https://sourceforge.net/projects/drc-fir/files/drc-fir/3.2.2/drc-3.2.2.tar.gz
- source = drc.diff
- sha1sums = 293e8f074408832af0be08cb05e3940cb9489968
- sha1sums = 9b8753984ba2f4af0a421add55d4f737a644c7eb
+ source = https://sourceforge.net/projects/drc-fir/files/drc-fir/3.2.3/drc-3.2.3.tar.gz
+ sha1sums = a23b43088c66ce9076ace16bac795e7bfa6c022b
pkgname = drc
diff --git a/PKGBUILD b/PKGBUILD
index d4d17a83e00a..a2c77ed22c92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jakob Dübel <jkbd@posteo.de>
pkgname=drc
-pkgver=3.2.2
+pkgver=3.2.3
pkgrel=1
pkgdesc="Digital Room Correction FIR filter generator"
arch=('x86_64' 'i686')
@@ -9,16 +9,9 @@ license=('GPL2')
depends=('gcc-libs')
optdepends=('octave: building graphs')
-source=("https://sourceforge.net/projects/drc-fir/files/drc-fir/$pkgver/$pkgname-$pkgver.tar.gz"
- "drc.diff")
+source=("https://sourceforge.net/projects/drc-fir/files/drc-fir/$pkgver/$pkgname-$pkgver.tar.gz")
-sha1sums=('293e8f074408832af0be08cb05e3940cb9489968'
- '9b8753984ba2f4af0a421add55d4f737a644c7eb')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np0 -i "${srcdir}/drc.diff"
-}
+sha1sums=('a23b43088c66ce9076ace16bac795e7bfa6c022b')
build() {
cd "$srcdir/$pkgname-$pkgver/source"
diff --git a/drc.diff b/drc.diff
deleted file mode 100644
index 66e76bf61021..000000000000
--- a/drc.diff
+++ /dev/null
@@ -1,55 +0,0 @@
-diff --git source/glsweep.c source/glsweep.c
-index 342aad6..188e3c1 100644
---- source/glsweep.c
-+++ source/glsweep.c
-@@ -32,9 +32,8 @@
- #include <stdlib.h>
- #include <math.h>
-
--/* Decommentare per abilitare la compilazione in doppia precisione */
--/* Uncomment to enable double precision computation */
--#define UseDouble
-+/* For the UseDouble option */
-+#include <drc.h>
-
- #ifdef UseDouble
- /* Tipo floating point usato per le elaborazioni */
-diff --git source/lsconv.c source/lsconv.c
-index 299fe55..5554f04 100644
---- source/lsconv.c
-+++ source/lsconv.c
-@@ -30,6 +30,7 @@
- #include <stdlib.h>
- #include <math.h>
- #include "fftsg_h.h"
-+#include "drc.h"
-
- /* Output stringhe con sync output e parametro */
- int sputsp(const char * s, const char * p)
-@@ -216,7 +217,7 @@ int main(int argc, char * argv[])
- }
- for(I = 0;I < IS;I++)
- {
-- if (fread(&RF,sizeof(float),1,IOF) < sizeof(float))
-+ if (fread(&RF,sizeof(float),1,IOF) != 1)
- {
- perror("Error while reading the inverse file");
- return 1;
-@@ -244,7 +245,7 @@ int main(int argc, char * argv[])
- Sweep[I] = (DLReal) 0.0;
- for(I = CS - IS,J = 0;J < RS;I++,J++)
- {
-- if (fread(&RF,sizeof(float),1,IOF) < sizeof(float))
-+ if (fread(&RF,sizeof(float),1,IOF) != 1)
- {
- perror("Error while reading the reference file");
- return 1;
-@@ -373,7 +374,7 @@ int main(int argc, char * argv[])
- }
- for(I = 0;I < SS;I++)
- {
-- if (fread(&RF,sizeof(float),1,IOF) < sizeof(float))
-+ if (fread(&RF,sizeof(float),1,IOF) != 1)
- {
- perror("Error while reading the sweep file");
- return 1;