summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Dübel2018-10-12 20:18:06 +0200
committerJakob Dübel2018-10-12 20:18:06 +0200
commitd8e2a3194e2e5b1d0b7418a31348f1ec32508409 (patch)
tree5f9bc92f4c550fe683030bbdc80b1eecb3d803bc
downloadaur-d8e2a3194e2e5b1d0b7418a31348f1ec32508409.tar.gz
Version 3.2.2 with patch.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--drc.diff55
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78582c7a344e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = drc
+ pkgdesc = Digital Room Correction
+ pkgver = 3.2.2
+ pkgrel = 1
+ url = http://drc-fir.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = gcc-libs
+ optdepends = octave: building graphs
+ source = https://sourceforge.net/projects/drc-fir/files/drc-fir/3.2.2/drc-3.2.2.tar.gz
+ source = drc.diff
+ sha1sums = 293e8f074408832af0be08cb05e3940cb9489968
+ sha1sums = 9b8753984ba2f4af0a421add55d4f737a644c7eb
+
+pkgname = drc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff8f504f72c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jakob Dübel <jkbd@posteo.de>
+pkgname=drc
+pkgver=3.2.2
+pkgrel=1
+pkgdesc="Digital Room Correction"
+arch=('x86_64' 'i686')
+url="http://drc-fir.sourceforge.net/"
+license=('GPL2')
+depends=('gcc-libs')
+optdepends=('octave: building graphs')
+
+source=("https://sourceforge.net/projects/drc-fir/files/drc-fir/$pkgver/$pkgname-$pkgver.tar.gz"
+ "drc.diff")
+
+sha1sums=('293e8f074408832af0be08cb05e3940cb9489968'
+ '9b8753984ba2f4af0a421add55d4f737a644c7eb')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np0 -i "${srcdir}/drc.diff"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/source"
+ make
+}
+
+package() {
+ install -dm644 "$pkgdir/usr/bin"
+
+ cd "$srcdir/$pkgname-$pkgver/source"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/drc.diff b/drc.diff
new file mode 100644
index 000000000000..66e76bf61021
--- /dev/null
+++ b/drc.diff
@@ -0,0 +1,55 @@
+diff --git source/glsweep.c source/glsweep.c
+index 342aad6..188e3c1 100644
+--- source/glsweep.c
++++ source/glsweep.c
+@@ -32,9 +32,8 @@
+ #include <stdlib.h>
+ #include <math.h>
+
+-/* Decommentare per abilitare la compilazione in doppia precisione */
+-/* Uncomment to enable double precision computation */
+-#define UseDouble
++/* For the UseDouble option */
++#include <drc.h>
+
+ #ifdef UseDouble
+ /* Tipo floating point usato per le elaborazioni */
+diff --git source/lsconv.c source/lsconv.c
+index 299fe55..5554f04 100644
+--- source/lsconv.c
++++ source/lsconv.c
+@@ -30,6 +30,7 @@
+ #include <stdlib.h>
+ #include <math.h>
+ #include "fftsg_h.h"
++#include "drc.h"
+
+ /* Output stringhe con sync output e parametro */
+ int sputsp(const char * s, const char * p)
+@@ -216,7 +217,7 @@ int main(int argc, char * argv[])
+ }
+ for(I = 0;I < IS;I++)
+ {
+- if (fread(&RF,sizeof(float),1,IOF) < sizeof(float))
++ if (fread(&RF,sizeof(float),1,IOF) != 1)
+ {
+ perror("Error while reading the inverse file");
+ return 1;
+@@ -244,7 +245,7 @@ int main(int argc, char * argv[])
+ Sweep[I] = (DLReal) 0.0;
+ for(I = CS - IS,J = 0;J < RS;I++,J++)
+ {
+- if (fread(&RF,sizeof(float),1,IOF) < sizeof(float))
++ if (fread(&RF,sizeof(float),1,IOF) != 1)
+ {
+ perror("Error while reading the reference file");
+ return 1;
+@@ -373,7 +374,7 @@ int main(int argc, char * argv[])
+ }
+ for(I = 0;I < SS;I++)
+ {
+- if (fread(&RF,sizeof(float),1,IOF) < sizeof(float))
++ if (fread(&RF,sizeof(float),1,IOF) != 1)
+ {
+ perror("Error while reading the sweep file");
+ return 1;