summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2019-07-19 11:15:03 -0700
committerMartin Diehl2019-07-19 11:15:59 -0700
commitdb97ef838a9b564ce68354d94de43a92905fc7bd (patch)
tree39ba44ceead9fb5ded6303f27133017fe02bcb7d
downloadaur-db97ef838a9b564ce68354d94de43a92905fc7bd.tar.gz
first try
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
-rw-r--r--dream3d.desktop10
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a2c6f458ba4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dream3d
+ pkgdesc = analysis tool for microstructure data
+ pkgver = 6.5.121
+ pkgrel = 1
+ arch = x86_64
+ license = custom: DREAM.3D License
+ depends = libpng12
+ source = http://dream3d.bluequartz.net/binaries/DREAM3D-6.5.121-Linux-x86_64.tar.gz
+ source = dream3d.desktop
+ sha256sums = 95711bd026bf5c56954c1e0460bcb5b9e75cc045d6030d7f3d3c38cbed969d0f
+ sha256sums = 1b920026ee87b3fdd7484292a1f151b260b9f36712346a2800f3a510dae99de4
+
+pkgname = dream3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cb34984ae77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Martin Diehl <m.diehl@mpie.de>
+pkgname=dream3d
+pkgver=6.5.121
+pkgrel=1
+pkgdesc='analysis tool for microstructure data'
+arch=('x86_64')
+license=('custom: DREAM.3D License')
+depends=('libpng12')
+source=(http://dream3d.bluequartz.net/binaries/DREAM3D-${pkgver}-Linux-x86_64.tar.gz
+ dream3d.desktop
+)
+sha256sums=(95711bd026bf5c56954c1e0460bcb5b9e75cc045d6030d7f3d3c38cbed969d0f
+ 1b920026ee87b3fdd7484292a1f151b260b9f36712346a2800f3a510dae99de4
+)
+package() {
+
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ cd $srcdir
+
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/opt/dream3d"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
+
+ cp -r DREAM3D-${pkgver}-Linux-x86_64/* $pkgdir/opt/dream3d/
+
+ ln -s $pkgdir/opt/dream3d/bin/DREAM3D $pkgdir/usr/bin/
+ ln -s $pkgdir/opt/dream3d/bin/PipelineRunner $pkgdir/usr/bin/
+
+ install -Dm644 DREAM3D-${pkgver}-Linux-x86_64/*.txt $pkgdir/usr/share/licenses/$pkgname/
+}
diff --git a/dream3d.desktop b/dream3d.desktop
new file mode 100644
index 000000000000..d3ebb56f9efb
--- /dev/null
+++ b/dream3d.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=DREAM.3D
+Comment=analysis tool for microstructure data
+Exec=DREAM3D
+Icon=/opt/dream3d/Help/DREAM3D/logo.png
+Terminal=false
+StartupNotify=false
+Categories=Application;