summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikos Toutountzoglou2023-01-18 21:28:15 +0100
committerNikos Toutountzoglou2023-01-18 21:28:15 +0100
commit918bafa47034ebb78959bd2877fdb34bbf8062a7 (patch)
tree05cd5ae609f9d762d47afc6bfa7335c9a7203c2b
parent0ddee7921e96ffd4652a48cd11d8573d1a16e6d4 (diff)
downloadaur-918bafa47034ebb78959bd2877fdb34bbf8062a7.tar.gz
initial version
-rw-r--r--.SRCINFO35
-rwxr-xr-x[-rw-r--r--]PKGBUILD48
2 files changed, 33 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b5260753c7b..794cc9fe8a8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = dreamchess
- pkgdesc = An open source chess game with OpenGL graphics and various chess board sets
- pkgver = 0.2.0
- pkgrel = 8
- url = http://www.dreamchess.org/
+ pkgdesc = DreamChess is an open source chess game. It comes with its own engine called Dreamer.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/dreamchess/dreamchess
arch = i686
arch = x86_64
license = GPL3
- makedepends = autoconf
- makedepends = automake
- depends = mesa
- depends = mxml
- depends = sdl_mixer
- depends = sdl_image
- source = dreamchess-0.2.0.tar.gz::http://sourceforge.net/projects/dreamchess/files/dreamchess/0.2.0/dreamchess-0.2.0.tar.gz/download
- source = add-lpthread.diff
- source = link-with-libm.diff
- source = dreamchess.desktop
- md5sums = 0e837e14819c1e7d0232c6beb4d5c185
- md5sums = 7b2505302f63ee06039acb146326f306
- md5sums = 53ea942ed0d004df11e4ee7b9bff9890
- md5sums = 6034deb046a5eeecd17e23dd68ae2f71
+ makedepends = flex
+ makedepends = bison
+ makedepends = cmake
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = expat
+ depends = glew
+ provides = dreamchess
+ conflicts = dreamchess
+ source = https://github.com/dreamchess/dreamchess/archive/refs/tags/0.3.0.tar.gz
+ sha256sums = b070a34acf69ed92e523902683d104abb295d78b6f37663f4668e929b9e90470
pkgname = dreamchess
-
diff --git a/PKGBUILD b/PKGBUILD
index 25c779e0557a..777a70f78049 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,26 @@
-# Maintainer: yugrotavele <yugrotavele at archlinux dot us>
-# Contributor: Arkham <arkham at archlinux dot us>
-# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+# Maintainer: Nikos Toutountzoglou <nikos.toutou@gmail.com>
pkgname=dreamchess
-pkgver=0.2.0
-pkgrel=8
-pkgdesc="An open source chess game with OpenGL graphics and various chess board sets"
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="DreamChess is an open source chess game. It comes with its own engine called Dreamer."
arch=('i686' 'x86_64')
-url="http://www.dreamchess.org/"
+url="https://github.com/dreamchess/dreamchess"
license=('GPL3')
-depends=('mesa' 'mxml' 'sdl_mixer' 'sdl_image')
-makedepends=('autoconf' 'automake')
-source=(${pkgname}-${pkgver}.tar.gz::http://sourceforge.net/projects/dreamchess/files/dreamchess/${pkgver}/${pkgname}-${pkgver}.tar.gz/download
- add-lpthread.diff
- link-with-libm.diff
- dreamchess.desktop)
-md5sums=('0e837e14819c1e7d0232c6beb4d5c185'
- '7b2505302f63ee06039acb146326f306'
- '53ea942ed0d004df11e4ee7b9bff9890'
- '6034deb046a5eeecd17e23dd68ae2f71')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'expat' 'glew')
+makedepends=('flex' 'bison' 'cmake')
+provides=('dreamchess')
+conflicts=('dreamchess')
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('b070a34acf69ed92e523902683d104abb295d78b6f37663f4668e929b9e90470')
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- # Patch
- patch -Np1 -i "$srcdir/add-lpthread.diff"
- patch -Np1 -i "$srcdir/link-with-libm.diff"
- autoreconf -i
-
- # Compile and install
- ./configure --prefix=/usr
- make
+ cd "$pkgname-$pkgver/cmake"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
- install -Dm 644 "$srcdir/dreamchess.desktop" "$pkgdir/usr/share/applications/dreamchess.desktop"
-}
+ cd "$pkgname-$pkgver/cmake"
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file