summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2016-06-29 11:25:38 +0930
committerSamuel Walladge2016-06-29 11:25:38 +0930
commitd89712e0a239741a3e9d219169752f41877ead22 (patch)
treeafdb6c6d08c80053e8753fe961125b15430bbed5
parent5dbb32d0e63105fe3eecb094d0a6a1986dfe07f8 (diff)
downloadaur-d89712e0a239741a3e9d219169752f41877ead22.tar.gz
update deps, fix configure prefix, fix arch array
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d1d96d3c020..134ca6b92303 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
# Generated by mksrcinfo v8
-# Wed Feb 3 12:28:23 UTC 2016
+# Wed Jun 29 01:53:37 UTC 2016
pkgbase = dreamchess-git
pkgdesc = DreamChess - OpenGL Chess Game
pkgver = 312.c7fad45
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dreamchess/dreamchess
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL
makedepends = git
makedepends = bison
@@ -13,8 +14,7 @@ pkgbase = dreamchess-git
depends = sdl_mixer
depends = sdl_image
depends = glew
- depends = libgl
- depends = expat
+ depends = hicolor-icon-theme
source = git://github.com/dreamchess/dreamchess.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 813e8516f91f..1f252d430c61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Samuel Walladge <samuel at swalladge dot id dot au>
pkgname=dreamchess-git
+_pkgname=dreamchess
pkgver=312.c7fad45
-pkgrel=2
+pkgrel=3
pkgdesc="DreamChess - OpenGL Chess Game"
-arch=('any')
+arch=('i686' 'x86_64')
url="https://github.com/dreamchess/dreamchess"
license=('GPL')
# tried to include all necessary deps and none that aren't
# please notify if list not fully correct
-depends=(mxml sdl_mixer sdl_image glew libgl expat)
+depends=(mxml sdl_mixer sdl_image glew hicolor-icon-theme)
makedepends=(git bison)
source=('git://github.com/dreamchess/dreamchess.git')
@@ -22,20 +23,16 @@ pkgver() {
}
build() {
- cd "${srcdir}/dreamchess"
+ cd "${srcdir}/${_pkgname}"
# must autoreconf or missing install-sh
autoreconf -fvi
- ./configure
+ ./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/dreamchess"
+ cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
-
- # removing man pages otherwise pacman complains of filesystem conflict.
- # not sure where the bug is, someone can check it out later
- rm -r ${pkgdir}/usr/local/share/man
}
# vim:set ts=2 sw=2 et: