summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2016-02-03 22:54:20 +1030
committerSamuel Walladge2016-02-03 22:54:20 +1030
commitdf3d96bc8c14cc5438d60944b50eaff62bd6e96c (patch)
tree70be2612a5e96f18c1cf9b640ab1caf55350a824
parenta433186e5ea7828927b2361b99cca6184884f653 (diff)
downloadaur-df3d96bc8c14cc5438d60944b50eaff62bd6e96c.tar.gz
fixed deps, made sure package buildable and installable
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fae725dfe66..7945f7492209 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
# Generated by mksrcinfo v8
-# Wed Feb 3 11:47:18 UTC 2016
+# Wed Feb 3 12:23:27 UTC 2016
pkgbase = dreamchess-git
pkgdesc = DreamChess - OpenGL Chess Game
pkgver = 312.c7fad45
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dreamchess/dreamchess
arch = any
license = GNU
makedepends = git
- depends = bison
+ makedepends = bison
depends = mxml
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = glew
+ depends = libgl
+ depends = expat
+ depends = libxext
source = git://github.com/dreamchess/dreamchess.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d5ffe5db1856..cb57291cc8ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
-# Maintainer: Samuel Walladge <swalladge at gmail dot com>
+# Maintainer: Samuel Walladge <samuel at swalladge dot id dot au>
pkgname=dreamchess-git
pkgver=312.c7fad45
-pkgrel=1
+pkgrel=2
pkgdesc="DreamChess - OpenGL Chess Game"
arch=('any')
url="https://github.com/dreamchess/dreamchess"
license=('GNU')
-depends=(bison mxml)
-makedepends=('git')
+
+# tried to include all necessary deps and none that aren't
+# please notify if list not fully correct
+depends=(mxml sdl_mixer sdl_image glew libgl expat libxext)
+makedepends=(git bison)
+
source=('git://github.com/dreamchess/dreamchess.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/dreamchess"
+ cd "${srcdir}/dreamchess"
echo "$(git rev-list --count HEAD).$(git log --pretty=format:'%h' -n 1)"
}
build() {
- cd "$srcdir/dreamchess"
+ cd "${srcdir}/dreamchess"
# must autoreconf or missing install-sh
autoreconf -fvi
./configure
@@ -26,8 +30,12 @@ build() {
}
package() {
- cd "$srcdir/dreamchess"
+ cd "${srcdir}/dreamchess"
make DESTDIR="${pkgdir}" install
+
+ # removing man pages otherwise pacman complains of filesystem conflict.
+ # not sure where the bug is, someone can check it out later
+ rm -r ${pkgdir}/usr/local/share/man
}
# vim:set ts=2 sw=2 et: