summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:03:44 -0400
committerKyle Keen2015-06-13 00:03:44 -0400
commit8a001a09fb8cf7fdbec8f416adf645c63ec7f0f2 (patch)
tree1ae4c5dbec9be865a3b4fb0c18d668c2cebb6bb5
downloadaur-8a001a09fb8cf7fdbec8f416adf645c63ec7f0f2.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eceeff1d1a4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dreampie
+ pkgdesc = A Python shell which is designed to be reliable and fun.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://dreampie.org
+ arch = any
+ license = GPL
+ depends = pygtksourceview2
+ optdepends = python2-matplotlib: for interactive plotting
+ source = dreampie-1.2.1.tar.gz::https://github.com/noamraph/dreampie/tarball/1.2.1
+ md5sums = 6d745ce46624ebce91e2aac67ebbfbf1
+
+pkgname = dreampie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..538d2c7ac500
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Kyle Keen <keenerd@gmail.com>
+
+# transition pkgbuild while figuring out python2/python3 versions
+
+pkgname=dreampie
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="A Python shell which is designed to be reliable and fun."
+arch=('any')
+url="http://dreampie.org"
+license=('GPL')
+depends=('pygtksourceview2')
+optdepends=('python2-matplotlib: for interactive plotting')
+source=($pkgname-$pkgver.tar.gz::https://github.com/noamraph/dreampie/tarball/$pkgver)
+md5sums=('6d745ce46624ebce91e2aac67ebbfbf1')
+
+build() {
+ # git sha in srcdir
+ cd "$srcdir/noamraph-dreampie"-*
+ # build won't work with py3
+ # but the later install is fine
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/noamraph-dreampie"-*
+ #if which python3; then
+ # python3 setup.py install --prefix=/usr --root="$pkgdir"
+ # mv "$pkgdir/usr/bin/dreampie" "$pkgdir/usr/bin/dreampie-py3"
+ #fi
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ find "$pkgdir/" -name '*.pyc' -delete
+ find "$pkgdir/" -type d -empty -delete
+}
+