summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-27 20:17:40 +0200
committerDimitris Kiziridis2020-03-27 20:17:40 +0200
commit9e9fcd95f7356505145b7d92b0a6b08871f7fd6a (patch)
tree523b8897ad9487ab28f7a6e29c140b0e9494dc44
downloadaur-9e9fcd95f7356505145b7d92b0a6b08871f7fd6a.tar.gz
Initial commmit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7558a679bb04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = drill
+ pkgdesc = Drill is a HTTP load testing application written in Rust inspired by Ansible syntax
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/fcsonline/drill
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = cargo
+ makedepends = pkgconf
+ depends = openssl
+ source = https://github.com/fcsonline/drill/archive/0.5.0.tar.gz
+ md5sums = ecafaa5eae61617cae8c08bb8358b338
+
+pkgname = drill
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dfd83a71906
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=drill
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Drill is a HTTP load testing application written in Rust inspired by Ansible syntax"
+url="https://github.com/fcsonline/drill"
+depends=('openssl')
+makedepends=('cargo' 'pkgconf')
+arch=('x86_64')
+license=('GPL-3.0')
+source=("${url}/archive/${pkgver}.tar.gz")
+md5sums=('ecafaa5eae61617cae8c08bb8358b338')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 example/*.yml -t "$pkgdir/usr/share/drill/example/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd target/release
+ install -Dm755 drill "$pkgdir/usr/bin/drill-rs"
+} \ No newline at end of file