summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2018-04-09 20:50:21 +0100
committerAlex Dewar2018-04-09 20:52:00 +0100
commit5e1fdb44137448a78b7585e59b9c3f3275cc4d6e (patch)
treebd9ca1217c4b2146cf44164d966abcddd8c2482c
downloadaur-5e1fdb44137448a78b7585e59b9c3f3275cc4d6e.tar.gz
initial commit: v0.3.9
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7dd026d7714
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = drive-bin
+ pkgver = 0.3.9
+ pkgrel = 1
+ url = https://github.com/odeke-em/drive
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = APACHE
+ provides = drive
+ conflicts = drive
+ source_x86_64 = drive-bin-0.3.9::https://github.com/odeke-em/drive/releases/download/v0.3.9/drive_linux
+ md5sums_x86_64 = a192d38419377aa27a45d90055c56a14
+ source_arm = drive-bin-0.3.9::https://github.com/odeke-em/drive/releases/download/v0.3.9/drive_armv5
+ md5sums_arm = 990d899bdff2e54cd401ece624a4f8be
+ source_armv6h = drive-bin-0.3.9::https://github.com/odeke-em/drive/releases/download/v0.3.9/drive_armv6
+ md5sums_armv6h = 812689b6bb2113948c8394854bbde47f
+ source_armv7h = drive-bin-0.3.9::https://github.com/odeke-em/drive/releases/download/v0.3.9/drive_armv7
+ md5sums_armv7h = 222be8926c35353f81baba014d926c71
+ source_aarch64 = drive-bin-0.3.9::https://github.com/odeke-em/drive/releases/download/v0.3.9/drive_armv8
+ md5sums_aarch64 = ecc56e8df5af018eab40097d261e862d
+
+pkgname = drive-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7d71f7637cec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+drive-bin-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70c37e955ab8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Dewar <alex.dewar@gmx.co.uk>
+
+pkgname=drive-bin
+pkgver=0.3.9
+pkgrel=1
+pkgdesc=""
+arch=("x86_64" "arm" "armv6h" "armv7h" "aarch64")
+url="https://github.com/odeke-em/drive"
+license=('APACHE')
+provides=("drive")
+conflicts=("drive")
+_url="$pkgname-$pkgver::https://github.com/odeke-em/drive/releases/download/v$pkgver/drive"
+source_x86_64=("${_url}_linux")
+source_arm=("${_url}_armv5")
+source_armv6h=("${_url}_armv6")
+source_armv7h=("${_url}_armv7")
+source_aarch64=("${_url}_armv8")
+md5sums_x86_64=("a192d38419377aa27a45d90055c56a14")
+md5sums_arm=("990d899bdff2e54cd401ece624a4f8be")
+md5sums_armv6h=("812689b6bb2113948c8394854bbde47f")
+md5sums_armv7h=("222be8926c35353f81baba014d926c71")
+md5sums_aarch64=("ecc56e8df5af018eab40097d261e862d")
+
+package() {
+ #install -Dm 755 "$pkgdir"/usr/bin
+ install -Dm 755 $pkgname-$pkgver "$pkgdir"/usr/bin/drive
+}