summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToolybird2024-04-20 09:11:39 +1000
committerToolybird2024-04-20 09:11:39 +1000
commitcaa70db9cf49c7934a1b9e16e26549cb72de5706 (patch)
tree1266a046c9b2686c04ac57b7ae605a8f292bfa66
parent0af3d7e38e65c001c377d8a02175cbb56084316c (diff)
downloadaur-driverctl.tar.gz
Upgrade to 0.115 and apply fixes
- remove unnecessary quotes - update to SPDX license indentifier - add missing systemd makedep - remove unnecessary install of common license
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5b109641929..bd63cfa17272 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = driverctl
pkgdesc = Device driver control utility
- pkgver = 0.111
+ pkgver = 0.115
pkgrel = 1
url = https://gitlab.com/driverctl/driverctl
arch = any
- license = LGPL2.1
+ license = LGPL-2.1-only
+ makedepends = systemd
depends = bash
optdepends = bash-completion: bash completion
- source = https://gitlab.com/driverctl/driverctl/-/archive/0.111/driverctl-0.111.tar.bz2
- sha256sums = 31a077a4bf620cb1026d849c53b58697a5812be48d07118aca70f6b8cd3d8d8e
+ source = https://gitlab.com/driverctl/driverctl/-/archive/0.115/driverctl-0.115.tar.bz2
+ sha256sums = 6939c98527ce11ac2c5d740199ac91392ebd8f0577471d6b45d8a4b8750a40dd
pkgname = driverctl
-
diff --git a/PKGBUILD b/PKGBUILD
index deecba8ec591..ff9b7d7a6946 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Toolybird <toolybird at tuta dot io>
pkgname=driverctl
-pkgver=0.111
+pkgver=0.115
pkgrel=1
pkgdesc="Device driver control utility"
-arch=('any')
+arch=(any)
url="https://gitlab.com/driverctl/driverctl"
-license=('LGPL2.1')
-depends=('bash')
+license=(LGPL-2.1-only)
+depends=(bash)
+makedepends=(systemd)
optdepends=('bash-completion: bash completion')
source=("https://gitlab.com/driverctl/driverctl/-/archive/$pkgver/driverctl-$pkgver.tar.bz2")
-sha256sums=('31a077a4bf620cb1026d849c53b58697a5812be48d07118aca70f6b8cd3d8d8e')
+sha256sums=('6939c98527ce11ac2c5d740199ac91392ebd8f0577471d6b45d8a4b8750a40dd')
package() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" SBINDIR=/usr/bin install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}