summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahuel Morata2017-11-17 13:13:00 -0300
committerNahuel Morata2017-11-17 13:13:00 -0300
commit7c99b63ab940db9f383dea2749fa68b904be8869 (patch)
tree9fd4734b759047c36d9056daec76e2c6686db3bd
downloadaur-7c99b63ab940db9f383dea2749fa68b904be8869.tar.gz
Ultima version de github
-rw-r--r--.INSTALL36
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
3 files changed, 87 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..4b0b4b485d9d
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,36 @@
+post_install() {
+ if [ -f /opt/drivesync/config.yml ]; then
+ rm /tmp/drivesync/config.yml
+ cp /opt/drivesync/config.yml /tmp/drivesync/config.yml
+ sudo rm -R /opt/drivesync
+ fi
+
+ sudo mv /tmp/drivesync/ /opt/
+
+ echo "To use type in console 'drivesync'"
+ echo "To modify the configuration, modify the file /opt/drivesync/config.yml"
+ echo "To add as cronjob use crontab -e and paste"
+ echo "'*/1 * * * * ruby /opt/drivesync/drivesync.rb' (without quote)"
+}
+
+post_upgrade() {
+ if [ -f /opt/drivesync/config.yml ]; then
+ rm /tmp/drivesync/config.yml
+ cp /opt/drivesync/config.yml /tmp/drivesync/config.yml
+ sudo rm -R /opt/drivesync
+ fi
+
+ sudo mv /tmp/drivesync/ /opt/
+
+ echo "To use type in console 'drivesync'"
+ echo "To modify the configuration, modify the file /opt/drivesync/config.yml"
+ echo "To add as cronjob use crontab -e and paste"
+ echo "'*/1 * * * * ruby /opt/drivesync/drivesync.rb' (without quote)"
+}
+
+post_remove() {
+ sudo rm /opt/drivesync
+ echo "Make sure to erase the cronjob with crontab -e"
+ echo "and remove the line 'alias drivesync='ruby /opt/drivesync/drivesync.rb'"
+ echo "from your .bashrc"
+}
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61644f7f2ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# vie nov 17 16:12:25 UTC 2017
+pkgbase = drivesync-git
+ pkgdesc = A command line utility that synchronizes your Google Drive files with a local folder on your machine
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/MStadlmeier/drivesync
+ install = .INSTALL
+ arch = any
+ license = MIT
+ depends = ruby
+ provides = drivesync
+ source = https://github.com/MStadlmeier/drivesync/archive/1.2.0.tar.gz
+ md5sums = 821d5a4da22cd473290727a7ea470f0b
+ sha256sums = fb32c3d89171ac4680e02d9325e042728baad40b74bcaff8c77742b0958d8388
+
+pkgname = drivesync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c445429c4ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nahuel Morata <nahuelmorata@gmail.com>
+pkgname=drivesync-git
+_origname="drivesync"
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A command line utility that synchronizes your Google Drive files with a local folder on your machine"
+arch=('any')
+url="https://github.com/MStadlmeier/drivesync"
+license=('MIT')
+depends=("ruby")
+provides=("drivesync")
+install=.INSTALL
+source=("https://github.com/MStadlmeier/$_origname/archive/$pkgver.tar.gz")
+md5sums=("821d5a4da22cd473290727a7ea470f0b")
+sha256sums=("fb32c3d89171ac4680e02d9325e042728baad40b74bcaff8c77742b0958d8388")
+
+prepare() {
+ gem install bundler
+ tar xf "$pkgver.tar.gz"
+}
+
+build() {
+ cd "$_origname-$pkgver"
+ bundle install
+}
+
+package() {
+ if [ ! -d /opt/drivesync ]; then
+ echo "alias drivesync='ruby /opt/drivesync/drivesync.rb'" >> ~/.bashrc
+ fi
+
+ mv -T $_origname-$pkgver /tmp/drivesync
+}